By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
438,611 Members | 2,296 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 438,611 IT Pros & Developers. It's quick & easy.

SQL30081N A communication error has been detected

P: n/a
Hi,

I installed DB2 V8.1 with fixpak 10, created a new database and can
connect to the database.

$ db2 connect to mkstest

Database Connection Information

Database server = DB2/LINUX 8.2.3
SQL authorization ID = DB2INST1
Local database alias = MKSTEST
After that I wanted to connect to the database by tcpip (client & server
is the same host!).

$ db2 catalog tcpip node mksdb remote $myIP server 50000
$ db2 catalog database mkstest as mkstcp at node mksdb
$ db2 LIST NODE DIRECTORY

Node Directory

Number of entries in the directory = 1

Node 1 entry:

Node name = MKSDB
Comment =
Directory entry type = LOCAL
Protocol = TCPIP
Hostname = $myIP
Service name = 5000

$ db2 LIST DATABASE DIRECTORY

System Database Directory

Number of entries in the directory = 3

Database 1 entry:

Database alias = TOOLSDB
Database name = TOOLSDB
Local database directory = /home/db2inst1
Database release level = a.00
Comment =
Directory entry type = Indirect
Catalog database partition number = 0
Alternate server hostname =
Alternate server port number =

Database 2 entry:

Database alias = MKSTCP
Database name = MKSTEST
Node name = MKSDB
Database release level = a.00
Comment =
Directory entry type = Remote
Catalog database partition number = -1
Alternate server hostname =
Alternate server port number =

Database 3 entry:

Database alias = MKSTEST
Database name = MKSTEST
Local database directory = /home/db2inst1
Database release level = a.00
Comment =
Directory entry type = Indirect
Catalog database partition number = 0
Alternate server hostname =
Alternate server port number =

Now the connection to the db using tcpip fails.

$ db2 connect to mkstcp
SQL30081N A communication error has been detected. Communication protocol
being used: "TCP/IP". Communication API being used: "SOCKETS". Location
where the error was detected: "$myIP". Communication function
detecting the error: "connect". Protocol specific error code(s): "111", "*",
"*". SQLSTATE=08001
The service is listening on port 5000
tcp 0 0 0.0.0.0:50000 0.0.0.0:* LISTEN 25797/db2tcpcm 0
Any idea what might be the problem?

Ralf

Nov 12 '05 #1
Share this Question
Share on Google+
4 Replies


P: n/a
Ian
Ralf Gross wrote:
$ db2 catalog tcpip node mksdb remote $myIP server 50000
$ db2 catalog database mkstest as mkstcp at node mksdb
$ db2 LIST NODE DIRECTORY

Node Directory

Number of entries in the directory = 1

Node 1 entry:

Node name = MKSDB
Comment =
Directory entry type = LOCAL
Protocol = TCPIP
Hostname = $myIP
Service name = 5000

[...]

Now the connection to the db using tcpip fails.

$ db2 connect to mkstcp
SQL30081N A communication error has been detected. Communication protocol
being used: "TCP/IP". Communication API being used: "SOCKETS". Location
where the error was detected: "$myIP". Communication function
detecting the error: "connect". Protocol specific error code(s): "111", "*",
"*". SQLSTATE=08001
The service is listening on port 5000
tcp 0 0 0.0.0.0:50000 0.0.0.0:* LISTEN 25797/db2tcpcm 0


That looks like port 50000, not 5000. Looks like your node directory
shows port 5000, but you say your database is listening on port 50000.

Nov 12 '05 #2

P: n/a
Ralf Gross wrote:
detecting the error: "connect". Protocol specific error code(s): "111", "*",


111 = ECONNREFUSED (on Linux)

I know I had similar problems under OS/2 some years ago...

Try "db2stop force" and "db2admin stop"

Then "db2admin start" - it should start without any error message. If
not, try "db2admin drop" and then "db2admin.exe CREATE /USER:benutzer
/PASSWORD:kennwort" (user and password should be the user/password used
during installation of DB2 or a user with enough right - no idea which
rights are needed under Linux).

Don't forget "db2start" at the end to start the database manager

Bernd

--
"Ja, alles meine Herren" sprach Fürst Lichnowsky. "Ooch det roochen?"
"Ja, auch das Rauchen." "Ooch im Tiergarten?" "Ja, auch im Tiergarten
darf geraucht werden, meine Herren." Und so endeten die Barrikadenkämpfe
des 18. März in Berlin
Nov 12 '05 #3

P: n/a
Ian wrote:
Ralf Gross wrote:
The service is listening on port 5000
tcp 0 0 0.0.0.0:50000 0.0.0.0:* LISTEN 25797/db2tcpcm 0


That looks like port 50000, not 5000. Looks like your node directory
shows port 5000, but you say your database is listening on port 50000.


You are right, I used the wrong port. cut&paste at it's best...

Thanks, Ralf
Nov 12 '05 #4

P: n/a
Bernd Hohmann wrote:
Ralf Gross wrote:
[db2 tcpip connection fails]


I just used the wrong port for the connection, 5000 instead of 50000...

Ralf
Nov 12 '05 #5

This discussion thread is closed

Replies have been disabled for this discussion.