By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
438,018 Members | 901 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 438,018 IT Pros & Developers. It's quick & easy.

SQL6031N after /etc/services was changed.

P: n/a
I am getting the following error when I run a db2 clp command.
$ db2 list applications
SQL6031N Error in the db2nodes.cfg file at line number "0". Reason
code
"11".
$ db2level
DB21085I Instance "db2inst7" uses DB2 code release "SQL07029" with
level
identifier "030A0105" and informational tokens "DB2 v7.1.0.111",
"s050516" and
"U803327".
I believe the /etc/services file was overwritten with a file that did
not have the entries for the db2 instance. I have added the
appropriate entries but I am still unable to run a clp command.
db2stop also errors out with the same message.

I am able to connect to db2 from a remote server but I cannot connect
from the database server.

Any suggestions on how to work through this?

Rick

Nov 12 '05 #1
Share this Question
Share on Google+
3 Replies


P: n/a
Make sure the service name in /etc/services matches the SVCENAME in the
DBM config. This is a dbm parameter and will probably require stopping
and restarting the instance to fix it. If you specify the numeric port
for SVCENAME then the /etc/services file isn't used. I'd still put the
entry there for documentation when using the numeric port number.

Phil Sherman

RickC wrote:
I am getting the following error when I run a db2 clp command.
$ db2 list applications
SQL6031N Error in the db2nodes.cfg file at line number "0". Reason
code
"11".
$ db2level
DB21085I Instance "db2inst7" uses DB2 code release "SQL07029" with
level
identifier "030A0105" and informational tokens "DB2 v7.1.0.111",
"s050516" and
"U803327".
I believe the /etc/services file was overwritten with a file that did
not have the entries for the db2 instance. I have added the
appropriate entries but I am still unable to run a clp command.
db2stop also errors out with the same message.

I am able to connect to db2 from a remote server but I cannot connect
from the database server.

Any suggestions on how to work through this?

Rick

Nov 12 '05 #2

P: n/a
Rick, as you can connect to the database remotely this means that
SVCENAME is set correctly.

Set the instance-owning partition port in /etc/services to:

DB2_instance_name port_number

Example for instance name "db2inst1":

DB2_db2inst1 60000/tcp

I did a quick test removing the line from existing services file and
got the same error message. Read more about Fast Communications Manager
(FCM) and the related entries in services file:

DB2_db2inst1 60000/tcp
DB2_db2inst1_1 60001/tcp
DB2_db2inst1_2 60002/tcp
DB2_db2inst1_END 60003/tcp

(the example is related to version 8 but the first line is also related
to version 7)

Regards, Artur

Nov 12 '05 #3

P: n/a
Thanks Artur that was very helpful. I didn't know that the FCM port(s)
were needed for a single partition database.
So each db2 instance requires at least two entries in the /etc/services
file

The first entry corresponds with SVCENAME. db2 get dbm cfg|grep
SVCENAME

The second entry (FCM port) must follow a naming convention.
DB2_{instance name} {port#}/tcp
DB2_{instance name}_END {port#+n}/tcp

I'm taking a backup of the /etc/services file in case it gets wiped out
again.

Thanks,
Rick C.

Nov 12 '05 #4

This discussion thread is closed

Replies have been disabled for this discussion.