By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
438,589 Members | 2,276 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 438,589 IT Pros & Developers. It's quick & easy.

Configuration Assistant problem

P: n/a

For the Configuration Assistant,
why gave me such errors when I try to add remote database "sample" on
linux (DB2 ESE UDB version 8)using "add database wizard" to my local
DB server
************************************************** *****************
SQL1005N The database alias "SAMPLE" already exists in either the
local database directory or system database directory.

Explanation:

The alias name specified has already been used. If no alias is
specified in the catalog database command, the database name is
used as the alias. When a database is created, the alias name is
the same as the database name.

This error may occur on the catalog database command when the
alias already exists in the system database directory.

On the create database command this error may occur in one of
the following situations:

o The alias already exists in the system database directory and
local database directory.

o The alias already exists in the system database directory but
not in the local database directory.

o The alias already exists in the local database directory but
not in the system database directory.

User Response:

For the catalog database command, uncatalog the alias from the
system database directory and resubmit your original command or
catalog the database with a different alias name.

For the create database command, do the following operations
with respect to the above 3 situations:

o Drop the database using the alias name. Resubmit your
original command.

o Uncatalog the alias. Resubmit your original command.

o Catalog the alias into the system database directory. Drop
the database using the same alias. Resubmit your original
command.

************************************************** **************
The problem seems that remote database I tried to connect has the name
conflict with database "sample" on my local DB server

Does anybody experience such a problem?
How can I rename the remote db name?

Any soutions will be appreciated!
Many thanks

Nov 12 '05 #1
Share this Question
Share on Google+
5 Replies


P: n/a
Probably because you already have a SAMPLE database on your local
machine. You can't have two databases with the exact same alias in your
local db directory. Try using a different name for the remote sample
database.

Larry Edelstein

Thames wrote:
For the Configuration Assistant,
why gave me such errors when I try to add remote database "sample" on
linux (DB2 ESE UDB version 8)using "add database wizard" to my local
DB server
************************************************** *****************
SQL1005N The database alias "SAMPLE" already exists in either the
local database directory or system database directory.

Explanation:

The alias name specified has already been used. If no alias is
specified in the catalog database command, the database name is
used as the alias. When a database is created, the alias name is
the same as the database name.

This error may occur on the catalog database command when the
alias already exists in the system database directory.

On the create database command this error may occur in one of
the following situations:

o The alias already exists in the system database directory and
local database directory.

o The alias already exists in the system database directory but
not in the local database directory.

o The alias already exists in the local database directory but
not in the system database directory.

User Response:

For the catalog database command, uncatalog the alias from the
system database directory and resubmit your original command or
catalog the database with a different alias name.

For the create database command, do the following operations
with respect to the above 3 situations:

o Drop the database using the alias name. Resubmit your
original command.

o Uncatalog the alias. Resubmit your original command.

o Catalog the alias into the system database directory. Drop
the database using the same alias. Resubmit your original
command.

************************************************** **************
The problem seems that remote database I tried to connect has the name
conflict with database "sample" on my local DB server

Does anybody experience such a problem?
How can I rename the remote db name?

Any soutions will be appreciated!
Many thanks

Nov 12 '05 #2

P: n/a
How can I rename remote database "sample" ?
thanks

Nov 12 '05 #3

P: n/a
Thames wrote:
How can I rename remote database "sample" ?


Just catalog it using a different name. You could also do this:

db2 UNCATALOG DB sample
db2 CATALOG DB sample AS local_s

Then you can catalog the remote SAMPLE database and still talk to the local
SAMPLE database. The latter will only be accessible by connecting to
LOCAL_S, though.

--
Knut Stolze
Information Integration Development
IBM Germany / University of Jena
Nov 12 '05 #4

P: n/a
I don't think there is a way. You'd need to logon to the remote machine,
drop database sample, and CREATE a new db on that machine calling it
something else. The other option is to leave the remote database named
SAMPLE and create an alias for it that is NOT SAMPLE. You would do this
using the UNCATALOG and CATALOG commands.

Larry Edelstein

Thames wrote:
How can I rename remote database "sample" ?
thanks

Nov 12 '05 #5

P: n/a
Hi Knut:

it works once I give an alias name for sample as u suggested

tons of thanks

Nov 12 '05 #6

This discussion thread is closed

Replies have been disabled for this discussion.