By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
438,226 Members | 1,027 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 438,226 IT Pros & Developers. It's quick & easy.

Backup fails with SQL2059

P: n/a
Hello,

we are using AIX 5.3 and DB2 V8.2 Fixlevel 9.

The attempt to backup a database of 50 GB leads to a message
SQL2059 and a 1 GB-fragment of the backup although there is sufficient
free space in the filesystem.

The diag2log offers no clues.

Before moving to Fixlevel 9 the backup worked well even with larger
file size.

Regards,
Jörg

--
Posted using the http://www.dbforumz.com interface, at author's request
Articles individually checked for conformance to usenet standards
Topic URL: http://www.dbforumz.com/DB2-Backup-f...ict249578.html
Visit Topic URL to contact author (reg. req'd). Report abuse: http://www.dbforumz.com/eform.php?p=864331
Nov 12 '05 #1
Share this Question
Share on Google+
2 Replies


P: n/a
I seem to recall seeing this error a long time ago on AIX systems when
there's plenty of space.

Try splitting the backup into two pieces in different directories. If
each goes to 1g then look for file size limitations. If the two files
grow to 500mb each and the backup quits; look for a quota issue. You'll
need assistance from your friendly system administrator to fix either.
Phil Sherman

schepers wrote:
Hello,

we are using AIX 5.3 and DB2 V8.2 Fixlevel 9.

The attempt to backup a database of 50 GB leads to a message
SQL2059 and a 1 GB-fragment of the backup although there is sufficient
free space in the filesystem.

The diag2log offers no clues.

Before moving to Fixlevel 9 the backup worked well even with larger
file size.

Regards,
Jörg

Nov 12 '05 #2

P: n/a
It looks like the ulimit for filesize is set to the default (1GB) for
the user that started db2. You can do ulimit -a as that user to
verify, or check the /etc/security/limits file (if you are unsure who
started db2) and confirm that all members of the SYSADM/CTRL/MAINT have
fsize set to -1. If a change is made to a ulimit you will need to
restart db2 as the settings are checked only at start time.

Jeff

Nov 12 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.