By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
438,590 Members | 2,191 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 438,590 IT Pros & Developers. It's quick & easy.

locks_held_top - Maximum Number of Locks Held monitor element

P: n/a
Description
The maximum number of locks held during this transaction.
It's not true. :-( When I tried found longest transactions I see
next picture:

uow_start_time T1, uow_stop T2, locks_held_top > 0

In monitor for statements

- connect
- declare/open/fetch
- close cursor (isolation CS or UR, readonly)
(T1) - commit
(T2) - commit

Between T1 and T2 no activities. But Locks_held_top > 0.

Bug or feature?

Andy

Nov 12 '05 #1
Share this Question
Share on Google+
3 Replies


P: n/a
How do you know you don't have catalog table or package locks? Get a
lock snapshot snapshot for the application to see what locks you're holding.

bughunter@ru wrote:
Description
The maximum number of locks held during this transaction.
It's not true. :-( When I tried found longest transactions I see
next picture:

uow_start_time T1, uow_stop T2, locks_held_top > 0

In monitor for statements

- connect
- declare/open/fetch
- close cursor (isolation CS or UR, readonly)
(T1) - commit
(T2) - commit

Between T1 and T2 no activities. But Locks_held_top > 0.

Bug or feature?

Andy

Nov 12 '05 #2

P: n/a
It's not possible and not interested AFTER T2. I need get snapshot
between T1 and T2. I will try catch this situation through periodical
snapshot.

Nov 12 '05 #3

P: n/a
I catch and see for applications

By monitor: locks_help_top - 18

By snapshot for locks:

Application idle time = 5 hours 52 minutes 1
second
Locks held by application = 0
Number of SQL requests since last commit = 0
UOW completion status = Committed - Commit
Statement
Statement type = Static SQL Statement
Statement = Static Commit

No locks in this transaction :-(

Nov 12 '05 #4

This discussion thread is closed

Replies have been disabled for this discussion.