By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
437,924 Members | 1,727 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 437,924 IT Pros & Developers. It's quick & easy.

Library issue

P: n/a
I am experiencing a library issue that appears to be environment
related but cannot isolate the cause. I would greatly appreciate any
assistance anyone could provide. Apologies for the length but I wanted
to be sure to include all relevant information.

My environment is as follows:
Operating System: IBM AIX 5.3 MR 2 64bit
DB2: 8.2 Fix Pack 2

All instances created as 64bit instances. I am able to start all
instances as well as the DAS and Fault Monitor. However when I attempt
to execute our application I receive the following error message:

2005/05/29 08:30:36 gasd info GWC: db2accept/SMMNU - VM error data:
exec(): 0509 -036 Cannot load program exe_adb2/bin/dscrun because of
the following errors:

0509-022 Cannot load module
/usr/opt/db2_08_01/lib64/libdb2.a(shr_64.o).

0509-150 Dependent module
/usr/opt/db2_08_01/lib/libdb2trcapi.a(shr_64.o) could not be loaded.

It would appear that a 32bit library is being referenced instead of the
64bit version and I don't know why. Currently my only solution is to
move the $DB2DIR/lib directory to another name and link the
$DB2DIR/lib64 directory to $DB2DIR/lib. However, this appears to be
preventing the DAS and Fault Monitor from starting.

I have verified that users LD_LIBRARY_PATH and LIBPATH include the
$DB2SQLLIBDIR/lib directory and that this directory is linked to the
$DB2DIR/lib64 directory.

Has anyone experienced this before? What am I missing? Thank you in
advance for any assistance.

Nov 12 '05 #1
Share this Question
Share on Google+
1 Reply


P: n/a
I've done additional digging and it would appear that issue is being
caused by a hard coded path to the $DB2DIR/lib directory in the vendors
compilation script. I am working with the vendor to correct.

Nov 12 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.