By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
438,287 Members | 1,287 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 438,287 IT Pros & Developers. It's quick & easy.

ERROR when using get db cfg command

P: n/a
Hi,

I'm running DB2 UDB v 7.2 FP 9.

I'm connected to my database (testdb) successfully as user db2admin.

then i tried to run the following command:

get db cfg for testdb

and i get the following error:

SQL1403N The username and/or password supplied is incorrect.
SQLSTATE=08004

I don't understand why I'm getting this error when I'm already
connected??

Any help would be appreciated!
Thanks!

Nov 12 '05 #1
Share this Question
Share on Google+
15 Replies


P: n/a
"Andy S." <an******@hotmail.com> wrote in message
news:11**********************@g14g2000cwa.googlegr oups.com...
Hi,

I'm running DB2 UDB v 7.2 FP 9.

I'm connected to my database (testdb) successfully as user db2admin.

then i tried to run the following command:

get db cfg for testdb

and i get the following error:

SQL1403N The username and/or password supplied is incorrect.
SQLSTATE=08004

I don't understand why I'm getting this error when I'm already
connected??

Any help would be appreciated!
Thanks!

Does db2admin have sysadm authority?

Try just using "get db cfg" after you have connected
Nov 12 '05 #2

P: n/a
What is the value for SYSADM_GROUP?? Make sure that db2admin is part of
this group.

Or you are trying to get the DB CFG for a remote database.

Cheers,

"Andy S." <an******@hotmail.com> wrote in message
news:11**********************@g14g2000cwa.googlegr oups.com...
Hi,

I'm running DB2 UDB v 7.2 FP 9.

I'm connected to my database (testdb) successfully as user db2admin.

then i tried to run the following command:

get db cfg for testdb

and i get the following error:

SQL1403N The username and/or password supplied is incorrect.
SQLSTATE=08004

I don't understand why I'm getting this error when I'm already
connected??

Any help would be appreciated!
Thanks!

Nov 12 '05 #3

P: n/a
In article <11**********************@g14g2000cwa.googlegroups .com>,
Andy S. (an******@hotmail.com) says...
Hi,

I'm running DB2 UDB v 7.2 FP 9.

I'm connected to my database (testdb) successfully as user db2admin.

then i tried to run the following command:

get db cfg for testdb

and i get the following error:

SQL1403N The username and/or password supplied is incorrect.
SQLSTATE=08004

I don't understand why I'm getting this error when I'm already
connected??

Any help would be appreciated!
Thanks!


You need to attach to the instance before running the command.
Nov 12 '05 #4

P: n/a
"Gert van der Kooij" <ge**@invalid.nl> wrote in message
news:MP************************@news.xs4all.nl...

You need to attach to the instance before running the command.


If you have already connected to a database, then an attach is not
necessary.
Nov 12 '05 #5

P: n/a
Hi,

I tried just "get db cfg" and I get the same error as first described.

How else can I check if db2admin has SYSADM authority??

Nov 12 '05 #6

P: n/a
In article <af********************@comcast.com>, Mark A
(no****@nowhere.com) says...
"Gert van der Kooij" <ge**@invalid.nl> wrote in message
news:MP************************@news.xs4all.nl...

You need to attach to the instance before running the command.


If you have already connected to a database, then an attach is not
necessary.


Since when did this change?
With DB2 V7 fp 6 which we still use at work you must attach
seperately, connect doesn't work.
Nov 12 '05 #7

P: n/a
the user "db2admin" is a part of the Windows Administrators group on
the machine on which the DB2 server is located. I'm trying to get the
DB CFG for a remote database - I'm typing my commands from a remote
client machine. When I type the "get db cfg for testdb" on the server
machine itself, it works. How can I achieve the same result from the
client machine??

Thanks!

Nov 12 '05 #8

P: n/a
In article <11**********************@g14g2000cwa.googlegroups .com>,
Andy S. (an******@hotmail.com) says...
the user "db2admin" is a part of the Windows Administrators group on
the machine on which the DB2 server is located. I'm trying to get the
DB CFG for a remote database - I'm typing my commands from a remote
client machine. When I type the "get db cfg for testdb" on the server
machine itself, it works. How can I achieve the same result from the
client machine??

Thanks!


As I said before you need to attach to the remote system:

db2 attach to <remote node> user db2admin using <pw>
db2 get db cfg for testdb
Nov 12 '05 #9

P: n/a
>> If you have already connected to a database, then an attach is not
necessary.


Since when did this change?
With DB2 V7 fp 6 which we still use at work you must attach
seperately, connect doesn't work.


If you are on a local machine, or telnet directly into the server, you only
have to connect. I did not realize the OP was connecting to a remote server
from windows.
Nov 12 '05 #10

P: n/a
Mark A wrote:
If you are on a local machine, or telnet directly into the server, you only
have to connect. I did not realize the OP was connecting to a remote server
from windows.


If you are on local machine and issue "db2 get db cfg for sample" - since this
command requires instance attachement - a locla attachment to the instance will
be performed for you - using your current credentials (id you are logged on to
the OS).

You may verify that by issuing "db2 attach" command which shows you current
attachement - before and after first command.

Local attachment is persistent (probably in anticipation of next isnatnce level
command) - so you have to explicitly detach if you desire to do so.

Jan M. Nelken
Nov 12 '05 #11

P: n/a
"Jan M. Nelken" <Un**********@Invalid.Domain> wrote in message
news:42********@news1.prserv.net...

If you are on local machine and issue "db2 get db cfg for sample" - since
this command requires instance attachement - a locla attachment to the
instance will be performed for you - using your current credentials (id
you are logged on to the OS).

You may verify that by issuing "db2 attach" command which shows you
current attachement - before and after first command.

Local attachment is persistent (probably in anticipation of next isnatnce
level command) - so you have to explicitly detach if you desire to do so.

Jan M. Nelken


The OP connected to a database first. I believe that once you connect to a
database, you are implicitly attached to corresponding instance.
Nov 12 '05 #12

P: n/a
Hi,
I guess you are not connected the database. You may check that using
the simple queries such as 'select 1 from sysibm.sysdummy1' after the
connect.

if it is not working then, try this.

connect to <remote db> user <remote user> using <remote password>

Steps to be Noted.
1. Make sure remote db is cataloged.
2. Make sure you authentication is correct.
3. Make sure the remote user is having the authority enough to perform
the required operation.

Connecting to the database will do the automatic attachment.
Cheers,
Thiru.
WantedToBeDBA.
WantedToBeDBA {at} gmail {dot} com

Nov 12 '05 #13

P: n/a
Hi,
I guess you are not connected the database. You may check that using
the simple queries such as 'select 1 from sysibm.sysdummy1' after the
connect.

if it is not working then, try this.

connect to <remote db> user <remote user> using <remote password>

Steps to be Noted.
1. Make sure remote db is cataloged.
2. Make sure you authentication is correct.
3. Make sure the remote user is having the authority enough to perform
the required operation.

Connecting to the database will do the automatic attachment.
Cheers,
Thiru.
WantedToBeDBA.
WantedToBeDBA {at} gmail {dot} com

Nov 12 '05 #14

P: n/a
In article <g9********************@comcast.com>, Mark A
(no****@nowhere.com) says...

The OP connected to a database first. I believe that once you connect to a
database, you are implicitly attached to corresponding instance.


Yes, that's true, but it will only work with V8. With V7 you
definitely need to attach to the remote node if you current user
doesn't have the needed authorizations.
Since the OP is using V7 his db connection doesn't help.
Nov 12 '05 #15

P: n/a

"Andy S." <an******@hotmail.com> wrote in message
news:11**********************@g14g2000cwa.googlegr oups.com...
the user "db2admin" is a part of the Windows Administrators group on
the machine on which the DB2 server is located.
I which case, you also need to configure

db2set -g DB2_GRP_LOOKUP=LOCAL

Thanks!

Nov 12 '05 #16

This discussion thread is closed

Replies have been disabled for this discussion.