By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
440,467 Members | 1,308 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 440,467 IT Pros & Developers. It's quick & easy.

"FIND" command is narrowed

P: n/a
In the ISPF editor I am using, for a particullar PO Dataset I am
getting the result of FIND statement narrowed down to the colums
48-56. i.e. if I give "FIND 'TO' ALL", the result I am getting as
"CHARS 'TO' - found 239 times within columns 48 to 56".

Please guide me as to how to make this PDS back to normal so that the
FIND command processes the whole 1 TO 80.

Thank you for the valuable time.

Regards,
PU

Nov 12 '05 #1
Share this Question
Share on Google+
2 Replies


P: n/a

"Praveen" <pr**************@gmail.com> wrote in message
news:11*********************@o13g2000cwo.googlegro ups.com...
In the ISPF editor I am using, for a particullar PO Dataset I am
getting the result of FIND statement narrowed down to the colums
48-56. i.e. if I give "FIND 'TO' ALL", the result I am getting as
"CHARS 'TO' - found 239 times within columns 48 to 56".

Please guide me as to how to make this PDS back to normal so that the
FIND command processes the whole 1 TO 80.

This question has nothing to do with DB2.

I don't recall the technique for resetting the FIND command any more but
there are several possible ways to find out. In no particular order, they
are:

1. Ask at a more appropriate newsgroup. I found one called
bit.listserv.ispf-l which looks like it could handle your question, although
it's not very active. I feel sure that you can find other forums that
discuss ISPF/PDF issues. Just do a Google web search on "ISPF forums" or
something like that and you should find some.

2. Look in the ISPF/PDF manuals. If you don't have any where you work, you
can probably find them online at the IBM website. Just use the search engine
there to find the manuals.

3. Ask someone else in your shop. Any of the veteran mainframe people in
your shop should be able to figure this out.

4. Or, best of all, try using the Help feature built into ISPF to find out
about all the rules governing FIND. Unless it has changed drastically in the
last few years, all the information you want is right on your terminal
already.

Rhino
Nov 12 '05 #2

P: n/a

"Rhino" <rh****@NOSPAM.sympatico.ca> wrote in message
news:7s*******************@news20.bellglobal.com.. .

"Praveen" <pr**************@gmail.com> wrote in message
news:11*********************@o13g2000cwo.googlegro ups.com...
In the ISPF editor I am using, for a particullar PO Dataset I am
getting the result of FIND statement narrowed down to the colums
48-56. i.e. if I give "FIND 'TO' ALL", the result I am getting as
"CHARS 'TO' - found 239 times within columns 48 to 56".

Please guide me as to how to make this PDS back to normal so that the
FIND command processes the whole 1 TO 80.


Okay, this question started bugging me :-) I used to use ISPF/PDF pretty
frequently but it's been years since I last used it. Still, I felt like I
ought to know the answer so I did a bit of digging.

The relevant manual set (assuming you are using ISPF V3R2) is available at
http://www-1.ibm.com/servers/eserver...m/49_srch.html. If
you use the "search text of all books" feature on that page and search for
FIND, you'll get a page that lists several books. If you select ISPF/PDF
Edit and Edit Macros, you'll see 124 hits on the word FIND. The second hit,
'Finding, Changing, and Excluding Data', gives the basic syntax of the FIND
command. Click on the link 'Column Limitations' on that page to see how to
specify the search columns.

In short, if you specify no column numbers in your FIND command, your search
should look in every column, i.e. to search for the string TO in every
column, all you should need to do is:

Find TO

However, it looks as if you are not specifying any search columns and the
scope of your FIND is still limited to columns 48 to 56. I'm almost positive
that this is because you have set BOUNDS to be columns 48 to 56. To verify
this, enter that command:

BOUNDS

It will almost certainly tell you show you that your bounds are columns 48
to 56 alone. Assuming this is the case, do this to reset BOUNDS to columns 1
to 80:

bounds 1 80

or

bounds

That should restore the scope of your FIND back to columns 1-80. Try the
FIND again and you should see that it is searching all of the columns, not
just 48-56.

Wow, this has really been a trip down Memory Lane ;-)

Rhino
Nov 12 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.