By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
458,112 Members | 1,601 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 458,112 IT Pros & Developers. It's quick & easy.

Kernel Parm Settings for DB2 v7.2 On SuSe 9.1

P: n/a
Does anyone have any recommendations for setting kernel.shmmax and/or
some of the other kernel parms that affect DB2, on a system that has
24-32GB of RAM available?

I am also looking for a good resouce that describes what these parms
really control.

I want DB2 to take advantage of the large amount of RAM. These
machines will have an average of 300-500 connections.
The databases are about 300GB.

I have looked at a lot of various docs out these on both IBM/DB2 and
Linux web sites, but I can't find any really detailed explanations of
the kernel.shm* parms, what they control (per session, per system ?),
and/or shared memory usage limits based upon the Suse version or DB2
version. I am running Suse 9.1 with DB2 v7.2 FixPak 10a.

Thanks in advance for any help from real world experience out there.

-Rick
Nov 12 '05 #1
Share this Question
Share on Google+
2 Replies


P: n/a
Rick wrote:
Does anyone have any recommendations for setting kernel.shmmax and/or
some of the other kernel parms that affect DB2, on a system that has
24-32GB of RAM available?

I am also looking for a good resouce that describes what these parms
really control.

I want DB2 to take advantage of the large amount of RAM. These
machines will have an average of 300-500 connections.
The databases are about 300GB.

I have looked at a lot of various docs out these on both IBM/DB2 and
Linux web sites, but I can't find any really detailed explanations of
the kernel.shm* parms, what they control (per session, per system ?),
and/or shared memory usage limits based upon the Suse version or DB2
version. I am running Suse 9.1 with DB2 v7.2 FixPak 10a.

Thanks in advance for any help from real world experience out there.

-Rick


Rick,

You really want to upgrade to V8 : V7.2 is now out of support. And V8
takes care of the kernel parameters autonomically. It also handles memory
much better in Linux. V8.2 (or Fixpack 7a on V8.1) also has some
exploitation of the 2.6 kernel

If you must stay at V7.2 then the following extract from my V8.2 db2diag.log
may give you some starters -

2004-10-27-20.37.08.868565+060 E3207662G363 LEVEL: Warning
PID : 5305 TID : 16384 PROC : db2sysc
INSTANCE: db2inst1 NODE : 000
FUNCTION: DB2 UDB, base sys utilities, DB2main, probe:9
MESSAGE : ADM0506I DB2 has automatically updated the "semmni" kernel
parameter
from "128" to the recommended value "1024".

2004-10-27-20.37.08.869124+060 E3208026G362 LEVEL: Warning
PID : 5305 TID : 16384 PROC : db2sysc
INSTANCE: db2inst1 NODE : 000
FUNCTION: DB2 UDB, base sys utilities, DB2main, probe:9
MESSAGE : ADM0506I DB2 has automatically updated the "msgmni" kernel
parameter
from "16" to the recommended value "1024".

2004-10-27-20.37.08.869245+060 E3208389G373 LEVEL: Warning
PID : 5305 TID : 16384 PROC : db2sysc
INSTANCE: db2inst1 NODE : 000
FUNCTION: DB2 UDB, base sys utilities, DB2main, probe:9
MESSAGE : ADM0506I DB2 has automatically updated the "shmmax" kernel
parameter
from "33554432" to the recommended value "268435456".

2004-10-27-20.37.08.869389+060 E3208763G433 LEVEL: Warning
PID : 5305 TID : 16384 PROC : db2sysc
INSTANCE: db2inst1 NODE : 000
FUNCTION: DB2 UDB, base sys utilities, DB2main, probe:9
MESSAGE : ADM0506I DB2 has automatically updated the "mapped_base" kernel
parameter from "0x40000000(hex) 1073741824(dec)" to the
recommended
value "0x20000000(hex) 536870912(dec)".
HTH

Phil
Nov 12 '05 #2

P: n/a
Philip Nelson wrote:
Rick,

You really want to upgrade to V8 : V7.2 is now out of support. And V8
takes care of the kernel parameters autonomically. It also handles
memory
much better in Linux. V8.2 (or Fixpack 7a on V8.1) also has some
exploitation of the 2.6 kernel


Besides that, V7 was never supported on anything beyond SUSE 8.1 if I
remember correctly.

--
Knut Stolze
Information Integration
IBM Germany / University of Jena
Nov 12 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.