By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
438,018 Members | 930 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 438,018 IT Pros & Developers. It's quick & easy.

Cannot create database....SQL1225N

P: n/a
Have installed DB2 v8.1 on a SUN 450, with an UltraSPARC-II processor
running at 248 MHz, 256 MB RAM, using Solaris 8.
Instance creation was smooth, but when trying to create a database I get
the error
db2 create db testdb

SQL1225N The request failed because an operating system process, thread,
or swap space limit was reached. SQLSTATE=57049

/etc/system:
set msgsys:msginfo_msgmax=65535
set msgsys:msginfo_msgmnb=65535
set shmsys:shminfo_shmmax=242000000
set msgsys:msginfo_msgseg=8192
set msgsys:msginfo_msgssz=16

df -k says that the swap is at 1% capacity

Someone got a clue?

(and yes, I have to run Solaris 8...
and yes, I have to use DB2 v8.1 (customer demand...))

Thanx in advance!
Nov 12 '05 #1
Share this Question
Share on Google+
3 Replies


P: n/a
Can you copy in the db2diag.log??

"Willis" <me**********@hotmail.com> wrote in message
news:84******************************@localhost.ta lkaboutdatabases.com...
Have installed DB2 v8.1 on a SUN 450, with an UltraSPARC-II processor
running at 248 MHz, 256 MB RAM, using Solaris 8.
Instance creation was smooth, but when trying to create a database I get
the error
db2 create db testdb

SQL1225N The request failed because an operating system process, thread,
or swap space limit was reached. SQLSTATE=57049

/etc/system:
set msgsys:msginfo_msgmax=65535
set msgsys:msginfo_msgmnb=65535
set shmsys:shminfo_shmmax=242000000
set msgsys:msginfo_msgseg=8192
set msgsys:msginfo_msgssz=16

df -k says that the swap is at 1% capacity

Someone got a clue?

(and yes, I have to run Solaris 8...
and yes, I have to use DB2 v8.1 (customer demand...))

Thanx in advance!

Nov 12 '05 #2

P: n/a
In article <84fe6fa7ff463d3f6d75142c8f978414
@localhost.talkaboutdatabases.com>, Willis (me**********@hotmail.com)
says...
Have installed DB2 v8.1 on a SUN 450, with an UltraSPARC-II processor
running at 248 MHz, 256 MB RAM, using Solaris 8.
Instance creation was smooth, but when trying to create a database I get
the error
db2 create db testdb

SQL1225N The request failed because an operating system process, thread,
or swap space limit was reached. SQLSTATE=57049

/etc/system:
set msgsys:msginfo_msgmax=65535
set msgsys:msginfo_msgmnb=65535
set shmsys:shminfo_shmmax=242000000
set msgsys:msginfo_msgseg=8192
set msgsys:msginfo_msgssz=16

df -k says that the swap is at 1% capacity

Someone got a clue?

(and yes, I have to run Solaris 8...
and yes, I have to use DB2 v8.1 (customer demand...))

Thanx in advance!


Run the db2osconf tool described in the Command Reference to check
the kernel settings, maybe some other parameter needs to changed
also.
Nov 12 '05 #3

P: n/a
Yes ... or check the kernel parms with those in the samples library.
256MB of RAM may be cutting it a bit close.

Larry Edelstein

Gert van der Kooij wrote:
In article <84fe6fa7ff463d3f6d75142c8f978414
@localhost.talkaboutdatabases.com>, Willis (me**********@hotmail.com)
says...
Have installed DB2 v8.1 on a SUN 450, with an UltraSPARC-II processor
running at 248 MHz, 256 MB RAM, using Solaris 8.
Instance creation was smooth, but when trying to create a database I get
the error

db2 create db testdb


SQL1225N The request failed because an operating system process, thread,
or swap space limit was reached. SQLSTATE=57049

/etc/system:
set msgsys:msginfo_msgmax=65535
set msgsys:msginfo_msgmnb=65535
set shmsys:shminfo_shmmax=242000000
set msgsys:msginfo_msgseg=8192
set msgsys:msginfo_msgssz=16

df -k says that the swap is at 1% capacity

Someone got a clue?

(and yes, I have to run Solaris 8...
and yes, I have to use DB2 v8.1 (customer demand...))

Thanx in advance!

Run the db2osconf tool described in the Command Reference to check
the kernel settings, maybe some other parameter needs to changed
also.


Nov 12 '05 #4

This discussion thread is closed

Replies have been disabled for this discussion.