467,926 Members | 1,427 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 467,926 developers. It's quick & easy.

collect sub-element statistics

I ran the runstats and try to collect sub-element statistics, but for some
reason, the value of that two fields in syscat.columns is always -1.
Does anyone have any idea?
Nov 12 '05 #1
  • viewed: 1393
Share:
3 Replies
"Fan Ruo Xin" <fa*****@sbcglobal.net> writes:
I ran the runstats and try to collect sub-element statistics, but for some
reason, the value of that two fields in syscat.columns is always -1. Does
anyone have any idea?


What syntax did you use that didn't work?

Regards,
--
Haider
Nov 12 '05 #2
Isn't there a variable that needs to be set for thLIKE statistics to be
collected.
Don't have mu docs available but...
HTH, Pierre.

Haider Rizvi wrote:
"Fan Ruo Xin" <fa*****@sbcglobal.net> writes:

I ran the runstats and try to collect sub-element statistics, but for some
reason, the value of that two fields in syscat.columns is always -1. Does
anyone have any idea?

What syntax did you use that didn't work?

Regards,


--
Pierre Saint-Jacques - Reply to: sescons at attglobal dot com
IBM DB2 Cerified Solutions Expert - Administration
SES Consultants Inc.
Nov 12 '05 #3
Thanks, Pierre&Haider,
Yes, I used LIKE STATISTICS when I did the runstats. And that is enough
thing we should do. I spent a couple of days try to figure out what the
problems are and finally gave up.
We support more than one db2 server and more than one physical database.
They all used the same way to migrate to Version8.1. I found out I failed to
collect sub-element statistics only on one of the database. I have no clue
what kind of things hide behind this database. Especially when all the other
statistics information I collected are just like what I expected.
Regards,
FRX

"Pierre Saint-Jacques" <se*****@attglobal.net> wrote in message
news:41**************@attglobal.net...
Isn't there a variable that needs to be set for thLIKE statistics to be
collected.
Don't have mu docs available but...
HTH, Pierre.

Haider Rizvi wrote:
"Fan Ruo Xin" <fa*****@sbcglobal.net> writes:

I ran the runstats and try to collect sub-element statistics, but for somereason, the value of that two fields in syscat.columns is always -1. Doesanyone have any idea?

What syntax did you use that didn't work?

Regards,


--
Pierre Saint-Jacques - Reply to: sescons at attglobal dot com
IBM DB2 Cerified Solutions Expert - Administration
SES Consultants Inc.

Nov 12 '05 #4

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

1 post views Thread by Paul Rowe | last post: by
9 posts views Thread by Frank Rizzo | last post: by
5 posts views Thread by Mrinal Kamboj | last post: by
3 posts views Thread by David | last post: by
48 posts views Thread by Ward Bekker | last post: by
9 posts views Thread by =?Utf-8?B?TWlrZTk5MDA=?= | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.