By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
437,851 Members | 1,752 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 437,851 IT Pros & Developers. It's quick & easy.

SP problem: SQL0727N with type "1". and SQLCODE "-551", SQLSTATE "42501"

P: n/a
SKC
What I did before problem occured?

Ans : When I REVOKE teh EXECUTE from a STORED PROCS called (SP1). and
then re GRANTED the EXECUTE permission to SP1.

SP1 is a SQL procedure on version 8 UDB.

What was the problem?

Ans : Application failed with the following error:
SQL0727N An error occurred during implicit system action type "1".
Information returned for the error includes SQLCODE "-551", SQLSTATE
"42501"
and message tokens "JAZZAPP1|EXECUTE|TJAZZ00.GETLEVELDETAILS".
SQLSTATE=56098
What steps I toook to find the root cause?

a. Granted EXECUTE to PACKAGE....NO USE
b. Granted EXECUTE to PROCEDURE....NO USE
c. Granted EXECUTE to SPECIFIC PROCEDURE....NO USE
d. RE-MIGRATED the SP1 with OWNER option.....NO USE
e. I tried to call SP ditectly (without help from application)...it
was working fine. That means...it is NOT working for application (only
for application).
f. Then thinking that some application related issue, I asked app.
team to look into their code...they verified their codes and
everything looks good.
g. Asked app. team to recycle the clones and websphere server...NO
USE...
h. then I looked inside the SP1 and realised that it was calling
another SP inside called SP2.
i. I granted EXECUTE to procedure, package, and specific
procedure...NO USE.
j. I MIGRATED the SP2 from dev box and gave EXECUTE to procedure,
package & specific procedure. Now, it WORKED FINE....:))

Now, it would be of great help if anyone explain what exactly happend
and why ?

Thanks in advance.....
Nov 12 '05 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.