472,977 Members | 2,047 Online
Bytes | Software Development & Data Engineering Community
Post Job

Home Posts Topics Members FAQ

Join Bytes to post your question to a community of 472,977 software developers and data experts.

SQL6048N/DBI1281E on SuSE 9, doesn't go away after reinstall


I'm having a hard time getting ESE 8.1 to run on a freshly installed
SuSE 9.0 linux box. It was actually up and running, but after a reboot
(one disk in the RAID 5 had to be replaced) it wouldn't start, saying
SQL6048N (communication error, see below).

As it was a test installation on a newly installed server I decided to
throw the DB2 installation away and start again (uninstalling DB2 and
removing everything DB2-related from /etc/, /var/db2 and /opt, and
removing the DB2 specific users).

Now, unfortunately, whenever I install from scratch and try to create an
instance, db2icrt complains about

SQL6048N A communication error occurred during START or STOP DATABASE
Update DBM cfg SYSADM_GROUP errcode = 8
DBI1281E The database manager configuration file could not be
(from db2icrt.log.xxxx)

I've tried quite a lot - if not all - possible combinations of

- using db2setup or db2icrt to create instances
- letting db2setup create the users, or create them beforehand
- making sure that rsh works for the instance owner and for root
(although I'm not trying to install a multi-node database)
- making sure that all DB2 users have write permissions in their homes
- increasing the numbers of IPC resources via /proc/sys/kernel/shmmax

Older threads in this group point to potential problems with
/etc/services, but it looks like the installer set up a range of ports:

DB2_db2inst2 60000/tcp
DB2_db2inst2_1 60001/tcp
DB2_db2inst2_2 60002/tcp
DB2_db2inst2_END 60003/tcp

Maybe someone has an idea of what's going wrong here?

Thanks a lot in advance,

Christoph Schmitz
Nov 12 '05 #1
1 4159
Christoph Schmitz wrote:

I'm having a hard time getting ESE 8.1 to run on a freshly installed
SuSE 9.0 linux box. It was actually up and running, but after a reboot
(one disk in the RAID 5 had to be replaced) it wouldn't start, saying
SQL6048N (communication error, see below).

You do know that SUSE 9 is not yet supported, don't you?
Have a look here: http://www-306.ibm.com/software/data...inux/validate/

Knut Stolze
Information Integration
IBM Germany / University of Jena
Nov 12 '05 #2

This thread has been closed and replies have been disabled. Please start a new discussion.

Similar topics

by: bonehead | last post by:
Okay, I've worked with RedHat and Fedora, but does anybody know if suse personal or suse pro comes with php/mysql? Or would I have to go with suse enterprise server to get them?
by: Data Goob | last post by:
This one has me stumped. How did SuSE disable the mail() function in their RPM'd version of PHP? ( This is their install-version of PHP with RPMs not what you download from PHP.net ) I have...
by: michael | last post by:
Hi. I am reasonably experienced with Python (and love it!) on Windows. I am a programmer that toils in c++ on Win 32 mostly but just to learn more, I am playing with Suse 9. Linux. Of course...
by: Denis S. Otkidach | last post by:
On all platfroms \w matches all unicode letters when used with flag re.UNICODE, but this doesn't work on SuSE 9.2: Python 2.3.4 (#1, Dec 17 2004, 19:56:48) on linux2 Type "help", "copyright",...
by: Jim Williams | last post by:
I am not able to get MYSQL running on Suse Linux Enterprise Server. I tried stopping with the command mysqld and it reported, "Shtudown Complete." Then when I tried to restart it with the...
by: Gellert, Andre | last post by:
Hi everybody, currenty we use Suse Linux 9 and the rpms with 7.4.0 downloaded from ftp://ftp.gmd.de/mirrors2/suse/ftp.suse.com/people/max/postgresql-7.4/ . I don't know how to contact the person...
by: SmoothJazz | last post by:
Hi All! I am wanting to setup/run PostgreSQL on my server (a SuSE Linux 9.2 distro) but I'm not quite sure which way to go. I have a few books on PostgreSQL but they don't seem to match the...
by: Vitaly Sedov | last post by:
I am trying to open up a .Net application on my localhost but I get a server error. On checking the Event log I found the following message: The server failed to load application '/LM/W3SVC'. The...
by: LittleMaster | last post by:
Dear Gurus Please help. I have installed DB2 8.2 on AIX 5.3. No apparent errors while installing. I opted the defaults to create the instance db2inst1 But when I do a db2start, I get the...
by: lllomh | last post by:
Define the method first this.state = { buttonBackgroundColor: 'green', isBlinking: false, // A new status is added to identify whether the button is blinking or not } autoStart=()=>{
by: isladogs | last post by:
The next Access Europe meeting will be on Wednesday 4 Oct 2023 starting at 18:00 UK time (6PM UTC+1) and finishing at about 19:15 (7.15PM) The start time is equivalent to 19:00 (7PM) in Central...
by: Aliciasmith | last post by:
In an age dominated by smartphones, having a mobile app for your business is no longer an option; it's a necessity. Whether you're a startup or an established enterprise, finding the right mobile app...
by: tracyyun | last post by:
Hello everyone, I have a question and would like some advice on network connectivity. I have one computer connected to my router via WiFi, but I have two other computers that I want to be able to...
by: giovanniandrean | last post by:
The energy model is structured as follows and uses excel sheets to give input data: 1-Utility.py contains all the functions needed to calculate the variables and other minor things (mentions...
by: NeoPa | last post by:
Hello everyone. I find myself stuck trying to find the VBA way to get Access to create a PDF of the currently-selected (and open) object (Form or Report). I know it can be done by selecting :...
by: Teri B | last post by:
Hi, I have created a sub-form Roles. In my course form the user selects the roles assigned to the course. 0ne-to-many. One course many roles. Then I created a report based on the Course form and...
by: isladogs | last post by:
The next Access Europe meeting will be on Wednesday 1 Nov 2023 starting at 18:00 UK time (6PM UTC) and finishing at about 19:15 (7.15PM) Please note that the UK and Europe revert to winter time on...
by: NeoPa | last post by:
Introduction For this article I'll be focusing on the Report (clsReport) class. This simply handles making the calling Form invisible until all of the Reports opened by it have been closed, when it...

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.