By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
431,899 Members | 1,066 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 431,899 IT Pros & Developers. It's quick & easy.

decimal point comma or period ? from DB2 Connect V8 to DB2 z/OS V7

P: n/a
Hi

Any suggestion would be fine.

I have installed DB2 Connect EE V8.1 (fixpak 4) at two different Windows
2000 Servers, both have the same regional settings.
I am connecting to the same DB2 z/OS subsystem running V7 from a DB2 Command
Window, and I do a "select decimal-field from table" - but at machine-a I
get the field with comma as decimal delimiter, and at machine-b I get period
as decimal delimiter.

I want it to be period - but at least I want them to be the same (either
comma or period).

I've checked db2cli.ini - but machines have the same options (no patch2=15).

Regards
Kim Bundgaard
Nov 12 '05 #1
Share this Question
Share on Google+
3 Replies


P: n/a

"Kim Bundgaard" <kib at kmd.dk> a écrit dans le message de
news:40*********************@dread12.news.tele.dk. ..
Hi

Any suggestion would be fine.

I have installed DB2 Connect EE V8.1 (fixpak 4) at two different Windows
2000 Servers, both have the same regional settings.
I am connecting to the same DB2 z/OS subsystem running V7 from a DB2 Command Window, and I do a "select decimal-field from table" - but at machine-a I
get the field with comma as decimal delimiter, and at machine-b I get period as decimal delimiter.

I want it to be period - but at least I want them to be the same (either
comma or period).

I've checked db2cli.ini - but machines have the same options (no patch2=15).
Regards
Kim Bundgaard

Hi Kim,

I think you should try to use patch2=15 in both db2cli.ini files, as this
forces the decimal separator to be a period. Try to use some other ODBC
tools, like Excel or QTODBC to check what you get.

Hope this helps,

JM
Nov 12 '05 #2

P: n/a
Hi

I have already tried the patch2=15 in db2cli.ini.
Nothing changes - I still have comma as decimal point when doing a select in
DB2 Command Window :

C:\>db2 select * from datatyper

X_TIMESTAMP X_DECIMAL X_CHAR10
-------------------------- --------- ----------
1995-08-03-16.00.13.000000 10,53 KUK
1995-08-04-12.00.32.319081 10,50 NYTX

/Kim

"Jean-Marc Blaise" <no****@nowhere.com> wrote in message
news:ca**********@news-reader5.wanadoo.fr...

"Kim Bundgaard" <kib at kmd.dk> a écrit dans le message de
news:40*********************@dread12.news.tele.dk. ..
Hi

Any suggestion would be fine.

I have installed DB2 Connect EE V8.1 (fixpak 4) at two different Windows
2000 Servers, both have the same regional settings.
I am connecting to the same DB2 z/OS subsystem running V7 from a DB2

Command
Window, and I do a "select decimal-field from table" - but at machine-a I get the field with comma as decimal delimiter, and at machine-b I get

period
as decimal delimiter.

I want it to be period - but at least I want them to be the same (either
comma or period).

I've checked db2cli.ini - but machines have the same options (no

patch2=15).

Regards
Kim Bundgaard

Hi Kim,

I think you should try to use patch2=15 in both db2cli.ini files, as this
forces the decimal separator to be a period. Try to use some other ODBC
tools, like Excel or QTODBC to check what you get.

Hope this helps,

JM

Nov 12 '05 #3

P: n/a
It looks like I have the solution.

We changed Windows 2000 Advanced Server Regional Settings (Defaults) to
English, at the machine-a. By mistake it was Danish. Udser Regional Settings
is Danish.
And then I uninstalled DB2 Connect EE V8 and reinstalled.

Now I get the period as decimal point.

But unfortunately I can't see what bit I changed in DB2.

/Kim

"Kim Bundgaard" <kib at kmd.dk> wrote in message
news:40*********************@dread12.news.tele.dk. ..
Hi

Any suggestion would be fine.

I have installed DB2 Connect EE V8.1 (fixpak 4) at two different Windows
2000 Servers, both have the same regional settings.
I am connecting to the same DB2 z/OS subsystem running V7 from a DB2 Command Window, and I do a "select decimal-field from table" - but at machine-a I
get the field with comma as decimal delimiter, and at machine-b I get period as decimal delimiter.

I want it to be period - but at least I want them to be the same (either
comma or period).

I've checked db2cli.ini - but machines have the same options (no patch2=15).
Regards
Kim Bundgaard

Nov 12 '05 #4

This discussion thread is closed

Replies have been disabled for this discussion.