By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
440,841 Members | 840 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 440,841 IT Pros & Developers. It's quick & easy.

DB2 SQL error: SQLCODE: -805, SQLSTATE: 51002, SQLERRMC: NULLID.SYSLH203 0X5359534C564C3031

P: n/a
hello, our application is running on db2 udb v8.1 win64 bit machine,
using db2jcc.jar for jdbc driver. i have this error happen, DB2 SQL
error: SQLCODE: -805, SQLSTATE: 51002, SQLERRMC: NULLID.SYSLH203
0X5359534C564C3031, before it has same error code but looking for
SYSHH203 instead of SYSLH203 , so i don't have idea how this happend,
cause when i do db2 list packages for schema nullid, i can't find the
requested package, and i am not sure why the server or the driver
request the package shouldn't exist, i don't know what exactly i
should do and what cause the problem, so i only do java DB2Binder with
size 70, the size has been increasing every time i saw this error
happend, and i want to know whether this is correct way, now the error
showed up again, should i just increase the size again? there are so
many packages existing already after i binding size 70, why DB2 still
request the packages which shouldn't exist? please help, urgent
Nov 12 '05 #1
Share this Question
Share on Google+
4 Replies


P: n/a
i read from some post thtat the db2cli.ini file have a keyword CLIPKG
=3 | 4 ... |30, defualt setting is 3 large packages are generated, so
how do i change this file? currently i don't see this file contain
keyword cLIPKG, the file looks like this
; Comment lines start with a semi-colon.

[tstcli1x]
uid=userid
pwd=password
autocommit=0
TableType="'TABLE','VIEW','SYSTEM TABLE'"

[tstcli2x]
; Assuming dbalias2 is a database in DB2 for MVS.
SchemaList="'OWNER1','OWNER2',CURRENT SQLID"

[MyVeryLongDBALIASName]
dbalias=dbalias3
SysSchema=MYSCHEMA

our application use jdbc driver, will this keyword changed help to fix
the problem?
Nov 12 '05 #2

P: n/a
i read from some post thtat the db2cli.ini file have a keyword CLIPKG
=3 | 4 ... |30, defualt setting is 3 large packages are generated, so
how do i change this file? currently i don't see this file contain
keyword cLIPKG, the file looks like this
; Comment lines start with a semi-colon.

[tstcli1x]
uid=userid
pwd=password
autocommit=0
TableType="'TABLE','VIEW','SYSTEM TABLE'"

[tstcli2x]
; Assuming dbalias2 is a database in DB2 for MVS.
SchemaList="'OWNER1','OWNER2',CURRENT SQLID"

[MyVeryLongDBALIASName]
dbalias=dbalias3
SysSchema=MYSCHEMA

our application use jdbc driver, will this keyword changed help to fix
the problem?
Nov 12 '05 #3

P: n/a
Hi,

what I lernde resently the java programs should free the space they used
in prepared statements an not wait for garbage collection. IBM says this
is not a defect but a design limitation ;-)

Using db2jdbcbind with a size of 20 (max ff) could help. But do not
solve the problem. The solution semms to be correct programming.

Friedmar
xixi wrote:
i read from some post thtat the db2cli.ini file have a keyword CLIPKG
=3 | 4 ... |30, defualt setting is 3 large packages are generated, so
how do i change this file? currently i don't see this file contain
keyword cLIPKG, the file looks like this
; Comment lines start with a semi-colon.

[tstcli1x]
uid=userid
pwd=password
autocommit=0
TableType="'TABLE','VIEW','SYSTEM TABLE'"

[tstcli2x]
; Assuming dbalias2 is a database in DB2 for MVS.
SchemaList="'OWNER1','OWNER2',CURRENT SQLID"

[MyVeryLongDBALIASName]
dbalias=dbalias3
SysSchema=MYSCHEMA

our application use jdbc driver, will this keyword changed help to fix
the problem?

Nov 12 '05 #4

P: n/a
Hi,

what I lernde resently the java programs should free the space they used
in prepared statements an not wait for garbage collection. IBM says this
is not a defect but a design limitation ;-)

Using db2jdbcbind with a size of 20 (max ff) could help. But do not
solve the problem. The solution semms to be correct programming.

Friedmar
xixi wrote:
i read from some post thtat the db2cli.ini file have a keyword CLIPKG
=3 | 4 ... |30, defualt setting is 3 large packages are generated, so
how do i change this file? currently i don't see this file contain
keyword cLIPKG, the file looks like this
; Comment lines start with a semi-colon.

[tstcli1x]
uid=userid
pwd=password
autocommit=0
TableType="'TABLE','VIEW','SYSTEM TABLE'"

[tstcli2x]
; Assuming dbalias2 is a database in DB2 for MVS.
SchemaList="'OWNER1','OWNER2',CURRENT SQLID"

[MyVeryLongDBALIASName]
dbalias=dbalias3
SysSchema=MYSCHEMA

our application use jdbc driver, will this keyword changed help to fix
the problem?

Nov 12 '05 #5

This discussion thread is closed

Replies have been disabled for this discussion.