By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
440,905 Members | 879 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 440,905 IT Pros & Developers. It's quick & easy.

Fixpack 5 ADC for Windows changes the decimal separator of decimalcolumns from a dot into a comma

P: n/a
Hi,

We upgraded the Windows ADC V8.1 to fixpack 5 on some Windows 2000
(Dutch Version) professional machines and something strange happened.
When we select decimal columns in our queries the decimal separator of
the decimal columns has become a comma while it was a dot.

Example resultset :

Before Fixpack 5:

40000.00
2030.00
304.23

After Fixpack 5:

40000,00
2030,00
304,23

Fixpack 5 is the first Fixpack we applied. We also saw the difference
using Quest Central. When we browsed some tables on a machine with
fixpack5 installed we saw the commas while on other machines without any
fixpacks we saw the dots.

Some interesting points to know:

* Our linux server (redhat 8.0 x86) was upgraded successfully to fixpack 5
* Our linux clients (slackware 9.0) were also upgraded successfully to
fixpack 5 and did not have the problem

* We have experimented with Country settings on Windows with rebooting
the machines but without changes in the resultsets

Well any advice would be very welcome.

Regards,

John Wheeler
Nov 12 '05 #1
Share this Question
Share on Google+
1 Reply


P: n/a
Today, I unstalled Fixpack 5 for 8.1 (FP5_WR21334_ADCL.exe) and instead
installed GA_ADCL.exe and I got the dot back in the decimal columns.
So we can continue our development. I've not a clue what the problem can be.

John Wheeler
John Wheeler wrote:
Hi,

We upgraded the Windows ADC V8.1 to fixpack 5 on some Windows 2000
(Dutch Version) professional machines and something strange happened.
When we select decimal columns in our queries the decimal separator of
the decimal columns has become a comma while it was a dot.

Example resultset :

Before Fixpack 5:

40000.00
2030.00
304.23

After Fixpack 5:

40000,00
2030,00
304,23

Fixpack 5 is the first Fixpack we applied. We also saw the difference
using Quest Central. When we browsed some tables on a machine with
fixpack5 installed we saw the commas while on other machines without any
fixpacks we saw the dots.

Some interesting points to know:

* Our linux server (redhat 8.0 x86) was upgraded successfully to fixpack 5
* Our linux clients (slackware 9.0) were also upgraded successfully to
fixpack 5 and did not have the problem

* We have experimented with Country settings on Windows with rebooting
the machines but without changes in the resultsets

Well any advice would be very welcome.

Regards,

John Wheeler


Nov 12 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.