469,603 Members | 2,069 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,603 developers. It's quick & easy.

Fixpack 5 ADC for Windows changes the decimal separator of decimalcolumns from a dot into a comma

Hi,

We upgraded the Windows ADC V8.1 to fixpack 5 on some Windows 2000
(Dutch Version) professional machines and something strange happened.
When we select decimal columns in our queries the decimal separator of
the decimal columns has become a comma while it was a dot.

Example resultset :

Before Fixpack 5:

40000.00
2030.00
304.23

After Fixpack 5:

40000,00
2030,00
304,23

Fixpack 5 is the first Fixpack we applied. We also saw the difference
using Quest Central. When we browsed some tables on a machine with
fixpack5 installed we saw the commas while on other machines without any
fixpacks we saw the dots.

Some interesting points to know:

* Our linux server (redhat 8.0 x86) was upgraded successfully to fixpack 5
* Our linux clients (slackware 9.0) were also upgraded successfully to
fixpack 5 and did not have the problem

* We have experimented with Country settings on Windows with rebooting
the machines but without changes in the resultsets

Well any advice would be very welcome.

Regards,

John Wheeler
Nov 12 '05 #1
1 2249
Today, I unstalled Fixpack 5 for 8.1 (FP5_WR21334_ADCL.exe) and instead
installed GA_ADCL.exe and I got the dot back in the decimal columns.
So we can continue our development. I've not a clue what the problem can be.

John Wheeler
John Wheeler wrote:
Hi,

We upgraded the Windows ADC V8.1 to fixpack 5 on some Windows 2000
(Dutch Version) professional machines and something strange happened.
When we select decimal columns in our queries the decimal separator of
the decimal columns has become a comma while it was a dot.

Example resultset :

Before Fixpack 5:

40000.00
2030.00
304.23

After Fixpack 5:

40000,00
2030,00
304,23

Fixpack 5 is the first Fixpack we applied. We also saw the difference
using Quest Central. When we browsed some tables on a machine with
fixpack5 installed we saw the commas while on other machines without any
fixpacks we saw the dots.

Some interesting points to know:

* Our linux server (redhat 8.0 x86) was upgraded successfully to fixpack 5
* Our linux clients (slackware 9.0) were also upgraded successfully to
fixpack 5 and did not have the problem

* We have experimented with Country settings on Windows with rebooting
the machines but without changes in the resultsets

Well any advice would be very welcome.

Regards,

John Wheeler


Nov 12 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

reply views Thread by Mihajlo Canic | last post: by
4 posts views Thread by John Bowman | last post: by
10 posts views Thread by T.K Kullervo | last post: by
3 posts views Thread by =?Utf-8?B?UGFvbG8=?= | last post: by
reply views Thread by guiromero | last post: by
reply views Thread by devrayhaan | last post: by
reply views Thread by gheharukoh7 | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.