473,695 Members | 2,647 Online
Bytes | Software Development & Data Engineering Community
+ Post

Home Posts Topics Members FAQ

can db2advis be told a non default schema?

1 New Member
Hi folks:

My environment:

db2level: "DB2 v8.1.0.48", "s040212", "MI00069", FixPak "5".
db2licm -l: DB2 Enterprise Server Edition
uname -a: Linux 2.6.17-1.2187_FC5smp

My question:

I am trying to run db2advis o a third party DB (restored by db2move). The schema for this db does not match any user on my system, and i am facing this puzzle: no user is able to find explain and advise tables, even though i created them with EXPLAIN.DLL. db2advis routinely prompts me with a SQLSTATE "42704" msg.

Things what i have already done:

-setting schema in the shell (tcsh): no way
-setting schema in the file containing the queries i want to be advised about: no way
-setting the schema in the db2cli.ini file: no way
-creating the advise and explain tables under the SYSTOOLS schema (as told in http://publib.boulder. ibm.com/infoce...dex.js p?topic= ): no way

What else can i try? Can db2advis to be told to search for tables under a non default schema? I could create a dummy user matching the schema name of the target DB, but i prefer a principled solution.

Thank you in advance.

(I apologize for crossposting)
May 10 '07 #1
0 1528

Sign in to post your reply or Sign up for a free account.

Similar topics

5
2354
by: Matthew Dauphinee | last post by:
Is anyone else having trouble using db2advis in V8 Fixpak 7? I am getting this: ===================================================================== Using user id as default schema name. Use -n option to specify schema SQL0805N Package "NULLID.DB2ADVIO 0X32415872414E4955" was not found. SQLSTATE=51002
0
1469
by: lelle | last post by:
Greetings, I'm playing around with db2advis and when I try -m C option it says ERROR <SQLCODE = 0>. Any ideas what might be wrong anyone? Thanx in advance /Lennart >>> $ uname -a
5
9183
by: dotyet | last post by:
I have been given the daunting task of sql query tuning. I am looking for ways to get started with that. I am on DB2 UDB 8.2 (8.1 with Fixpak 8) on Windows. One point which I could think about starting from is the db2 design advisor. However, whenever I try to execute the db2advis utility I get the following error: C:\db_tuning>db2advis -d DB_TEST1 -user db2admin/db2admin -i query_1.sql Using user id as default schema name. Use -n...
5
4984
by: lennart | last post by:
Here's the scenario. Take backup on production machine Restore backup on development machine OS and fixpak identical, but - and I suspect this has something to do with it - the dbadm user differs between prod and dev. drop explain tables and recreate them for dbadm on dev.
0
2257
by: Eil | last post by:
Have 2 databases under the same db2 udb instance (aix 5.3.0.0, db2 udb V8.1, fixpak 9). Able to run the db2advis command successfully against one database. On the other database, always receive the following error. Any ideas/info would be greatly appreciated. Thanks! Using user id as default schema name. Use -n option to specify schema CALL SYSPROC.GET_DBSIZE_INFO failed (workaround - use -l) SQL0444N Routine...
0
1554
by: ChrisC | last post by:
Hi. I'm attempting to get DB2ADVIS to analyze some SQL that I have to determine if any MDC tables would be appropriate (well, at least to know what DB2 thinks). Unfortunately, I'm running into issues. My SQL is using unqualified tables (generated from a tool), and I'd like to be able to specify a specific schema that it should look for these tables in.
2
4145
by: Roger | last post by:
i am trying to run advise using the following parameter and i get this error against one of the database : db2advis -d db1 -i test.sql Using user id as default schema name. Use -n option to specify schema SQL0818N A timestamp conflict occurred. SQLSTATE=51003 ************************************* * CONTENTS OF SQLCA *
0
3538
by: db2dbdba | last post by:
Hi all, I am getting the following problem when i run the db2advis. ]$ db2advis -d sample -i name3.sql -n db2inst1 -o db2advise.out 0 solutions were evaluated by the advisor exiting with error code
0
2187
by: suniltcs | last post by:
When I run DB2advis , i get below error message. ). db2advis -d aqwrwist -l -1 -s "select * from wis.cond with ur;" Using user id as default schema name. Use -n option to specify schema SQL0818N A timestamp conflict occurred. SQLSTATE=51003
0
8617
marktang
by: marktang | last post by:
ONU (Optical Network Unit) is one of the key components for providing high-speed Internet services. Its primary function is to act as an endpoint device located at the user's premises. However, people are often confused as to whether an ONU can Work As a Router. In this blog post, we’ll explore What is ONU, What Is Router, ONU & Router’s main usage, and What is the difference between ONU and Router. Let’s take a closer look ! Part I. Meaning of...
0
8553
by: Hystou | last post by:
Most computers default to English, but sometimes we require a different language, especially when relocating. Forgot to request a specific language before your computer shipped? No problem! You can effortlessly switch the default language on Windows 10 without reinstalling. I'll walk you through it. First, let's disable language synchronization. With a Microsoft account, language settings sync across devices. To prevent any complications,...
0
8971
jinu1996
by: jinu1996 | last post by:
In today's digital age, having a compelling online presence is paramount for businesses aiming to thrive in a competitive landscape. At the heart of this digital strategy lies an intricately woven tapestry of website design and digital marketing. It's not merely about having a website; it's about crafting an immersive digital experience that captivates audiences and drives business growth. The Art of Business Website Design Your website is...
1
8822
by: Hystou | last post by:
Overview: Windows 11 and 10 have less user interface control over operating system update behaviour than previous versions of Windows. In Windows 11 and 10, there is no way to turn off the Windows Update option using the Control Panel or Settings app; it automatically checks for updates and installs any it finds, whether you like it or not. For most users, this new feature is actually very convenient. If you want to control the update process,...
1
6483
isladogs
by: isladogs | last post by:
The next Access Europe User Group meeting will be on Wednesday 1 May 2024 starting at 18:00 UK time (6PM UTC+1) and finishing by 19:30 (7.30PM). In this session, we are pleased to welcome a new presenter, Adolph Dupré who will be discussing some powerful techniques for using class modules. He will explain when you may want to use classes instead of User Defined Types (UDT). For example, to manage the data in unbound forms. Adolph will...
0
4332
by: TSSRALBI | last post by:
Hello I'm a network technician in training and I need your help. I am currently learning how to create and manage the different types of VPNs and I have a question about LAN-to-LAN VPNs. The last exercise I practiced was to create a LAN-to-LAN VPN between two Pfsense firewalls, by using IPSEC protocols. I succeeded, with both firewalls in the same network. But I'm wondering if it's possible to do the same thing, with 2 Pfsense firewalls...
0
4570
by: adsilva | last post by:
A Windows Forms form does not have the event Unload, like VB6. What one acts like?
2
2251
muto222
by: muto222 | last post by:
How can i add a mobile payment intergratation into php mysql website.
3
1970
bsmnconsultancy
by: bsmnconsultancy | last post by:
In today's digital era, a well-designed website is crucial for businesses looking to succeed. Whether you're a small business owner or a large corporation in Toronto, having a strong online presence can significantly impact your brand's success. BSMN Consultancy, a leader in Website Development in Toronto offers valuable insights into creating effective websites that not only look great but also perform exceptionally well. In this comprehensive...

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.