473,560 Members | 2,953 Online
Bytes | Software Development & Data Engineering Community
+ Post

Home Posts Topics Members FAQ

DB2 V8.2 install on Redhat 3.0 - AMD 64 bit

I downloaded the newest 64 bit SDK for IBM and installed it.
I downloaded and installed the C58SBML.tar - Db2 distribution for 64
bit AMD

The install worked and I created and instance however I can't run any
of the gui tools.

I get a message
$dbcc
CLI0622E: Error accessing JDBC administration service extensions.
When I run a db2level I get:
$db2level
DB21085I Instance "db2inst2" uses "64" bits and DB2 code release
"SQL08020"
with level identifier "03010106".
Informational tokens are "DB2 v8.1.1.64", "s040812", "MI00089", and
FixPak "7".
Product is installed at "/opt/IBM/db2/V8.1".
Any ideas ?

Nov 12 '05 #1
4 1618
Try updating the admin cfg for the JDK_PATH and JDK_64_PATH

For example:

db2 update admin cfg using JDK_PATH /opt/IBMJava2-142
db2 update admin cfg using JDK_64_PATH /opt/IBMJava2-142

Your JDK 64 path is probably different than the one specified above, so
you will need to change it. Check the install path under directory /opt
for Linux systems.

stop and start the db2 administrative server (db2admin stop, db2admin
start). You may need to be logged on as the das owner (default dasusr1).

Nov 12 '05 #2
I performed the above steps with the same end result.
$dbcc
CLI0622E: Error accessing JDBC administration service extensions.

Nov 12 '05 #3
I tried installing the 32bit db2 on a Redhat 3.0 machine.
Install had no errors. I was able to create a database and run dbcc no
problem.

So, does db2 gui tools work on 64 bit install? Or is it bug?

Can anybody tell me the workaround to get the tools running ?
Help.
JD

Nov 12 '05 #4
dunleav1 wrote:
I tried installing the 32bit db2 on a Redhat 3.0 machine.
Install had no errors. I was able to create a database and run dbcc no
problem.

So, does db2 gui tools work on 64 bit install? Or is it bug?

Can anybody tell me the workaround to get the tools running ?
Help.
JD


The DB2 tools need to run a JVM of the same bit width as the instance,
therefore your 64-bit db2 instance needs to have it's JDK_PATH config
parm pointing to a 64-bit JVM. You'll need to get this 64-bit JVM on
your own, since it's not included as part of the db2 install on AMD64.

Another option is to update your instance to use 32-bit (db2iupdt -w 32
.... ) and set the JDK_PATH to point to the 32-bit JVM installed by DB2.
Nov 12 '05 #5

This thread has been closed and replies have been disabled. Please start a new discussion.

Similar topics

1
1849
by: Dave | last post by:
Hello All, I've created a problem by not reading instruction and now I don't know what to do :( I tried to install 9i on my redhat 9.0 box as myself without going thru the proper procedure of creating the oracle user/dba group etc. Didn't work so I had to break down and read to directions :) Now I believe I have things setup properly, I...
0
2364
by: Eric Raymond | last post by:
When installing the rpms (or the tar file) onto Red Hat Enteprise Linux AS Beta 1 (Taroon), we get the follwing error: Installing all prepared tables /usr/bin/mysql_install_db: line 1: 7690 Segmentation fault /usr/sbin/mysqld --bootstrap --skip-grant-tables --basedir=/ --datadir=/var/lib/mysql --skip-innodb --skip-bdb Installation of...
14
4018
by: Lou | last post by:
When I did my RedHat9 install, I choose Workstation and customized the packages I wanted install. As a part of that customization, I chose mySQL DB; however, I can't seem to find any RedHat documentation that says how to get to these installed packages. I would like to just start using them, but not sure where to start. Any hints to get up...
4
1845
by: KJemison | last post by:
Well.... just wanted to know if the people at the MySQL.org site ever look at the posts in this group. If they do, they can possibly us a little constructive criticism from a slightly irritated customer. Seems to me that if someone installs Redhat 9 with MySQL from the original CD source which is version 3.23.54a and then follows the...
1
2318
by: Jean-Christian Imbeault | last post by:
On my RH 9.0 linux system when ./configuring 7.3.4 I get an error about not finding the readline libs, however both the readline and readline-devel rpms are installed: # rpm -qa | grep readline readline-4.3-5 readline-devel-4.3-5 What library/rpm am I missing?
8
6274
by: lawrence k | last post by:
I've installed Apache 1.3.36 on my Redhat EL 3 machine. Now I'm trying to install PHP 5.1.4. I can not get the ./configure command to work. I keep getting this error: configure: error: Invalid Apache directory - unable to find httpd.h under /usr/local/apache/include So then I run this command: find / -name httpd.h
3
5619
by: TonyHa | last post by:
Hello I try to install boost_1_33_1 on RedHat Linux. I have downloaded boost into /user/dtgtools/tmp and I try to install it into /user/dtgtools/packages/boost. I use the following commands: export PYTHON_ROOT="/user/dtgtools/packages/python/2.5"
119
4420
by: Rhino | last post by:
One of my friends, Scott, is a consultant who doesn't currently have newsgroup access so I am asking these questions for him. I'll be telling him how to monitor the answers via Google Newsgroup searches. Scott has heard a lot of hype about DB2 and Oracle and is trying to understand the pros and cons of each product. I'm quite familiar with...
0
1977
by: carex | last post by:
Hi, A few years ago (2000 ?) I installed an oracle client on a linux server (oracle8iR2 on Debian Woody) and everything went beautifully. (with DBD::Oracle) Now, I need an oracle client on my new laptop. (debian Sarge) I tried oracle 10g instant client but whitout success. See below.
0
7632
marktang
by: marktang | last post by:
ONU (Optical Network Unit) is one of the key components for providing high-speed Internet services. Its primary function is to act as an endpoint device located at the user's premises. However, people are often confused as to whether an ONU can Work As a Router. In this blog post, we’ll explore What is ONU, What Is Router, ONU & Router’s main...
0
7841
Oralloy
by: Oralloy | last post by:
Hello folks, I am unable to find appropriate documentation on the type promotion of bit-fields when using the generalised comparison operator "<=>". The problem is that using the GNU compilers, it seems that the internal comparison operator "<=>" tries to promote arguments from unsigned to signed. This is as boiled down as I can make it. ...
0
8066
jinu1996
by: jinu1996 | last post by:
In today's digital age, having a compelling online presence is paramount for businesses aiming to thrive in a competitive landscape. At the heart of this digital strategy lies an intricately woven tapestry of website design and digital marketing. It's not merely about having a website; it's about crafting an immersive digital experience that...
0
7920
tracyyun
by: tracyyun | last post by:
Dear forum friends, With the development of smart home technology, a variety of wireless communication protocols have appeared on the market, such as Zigbee, Z-Wave, Wi-Fi, Bluetooth, etc. Each protocol has its own unique characteristics and advantages, but as a user who is planning to build a smart home system, I am a bit confused by the...
1
5458
isladogs
by: isladogs | last post by:
The next Access Europe User Group meeting will be on Wednesday 1 May 2024 starting at 18:00 UK time (6PM UTC+1) and finishing by 19:30 (7.30PM). In this session, we are pleased to welcome a new presenter, Adolph Dupré who will be discussing some powerful techniques for using class modules. He will explain when you may want to use classes...
0
5175
by: conductexam | last post by:
I have .net C# application in which I am extracting data from word file and save it in database particularly. To store word all data as it is I am converting the whole word file firstly in HTML and then checking html paragraph one by one. At the time of converting from word file to html my equations which are in the word document file was convert...
0
3605
by: TSSRALBI | last post by:
Hello I'm a network technician in training and I need your help. I am currently learning how to create and manage the different types of VPNs and I have a question about LAN-to-LAN VPNs. The last exercise I practiced was to create a LAN-to-LAN VPN between two Pfsense firewalls, by using IPSEC protocols. I succeeded, with both firewalls in...
1
2047
by: 6302768590 | last post by:
Hai team i want code for transfer the data from one system to another through IP address by using C# our system has to for every 5mins then we have to update the data what the data is updated we have to send another system
1
1169
muto222
by: muto222 | last post by:
How can i add a mobile payment intergratation into php mysql website.

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.