472,972 Members | 2,048 Online
Bytes | Software Development & Data Engineering Community
Post Job

Home Posts Topics Members FAQ

Join Bytes to post your question to a community of 472,972 software developers and data experts.

valgrind error - "failed to start tool 'memcheck' for platform x86-linux" no such fil

365 100+
valgrind error - "failed to start tool 'memcheck' for platform x86-linux" no such file or dir

copied all lib and bin files which are generated after I compiled valgrind package, when I run my exe with valgrind, I am getting above error, any idea?

-rw-r--r-- 1 0 0 27934 default.supp
-rwxr-xr-x 1 0 0 4636305 cachegrind-x86-linux
-rwxr-xr-x 1 0 0 4891451 callgrind-x86-linux
-rwxr-xr-x 1 0 0 4857510 drd-x86-linux
-rwxr-xr-x 1 0 0 4519362 exp-bbv-x86-linux
-rwxr-xr-x 1 0 0 4729657 exp-ptrcheck-x86-linux
-rwxr-xr-x 1 0 0 4837460 helgrind-x86-linux
-rwxr-xr-x 1 0 0 4529944 lackey-x86-linux
-rwxr-xr-x 1 0 0 4568883 massif-x86-linux
-rwxr-xr-x 1 0 0 5040139 memcheck-x86-linux
-rwxr-xr-x 1 0 0 4509675 none-x86-linux
-rwxr-xr-x 1 0 0 72136 vgpreload_memcheck-x86-linux.so
-rwxr-xr-x 1 0 0 37223 vgpreload_massif-x86-linux.so
-rwxr-xr-x 1 0 0 107935 vgpreload_helgrind-x86-linux.so
-rwxr-xr-x 1 0 0 45354 vgpreload_exp-ptrcheck-x86-linux.so
-rwxr-xr-x 1 0 0 170657 vgpreload_drd-x86-linux.so
-rwxr-xr-x 1 0 0 6765 vgpreload_core-x86-linux.so

rwxr-xr-x 1 0 0 40959 callgrind_annotate
-rwxr-xr-x 1 0 0 13662 callgrind_control
-rwxr-xr-x 1 0 0 32064 cg_annotate
-rwxr-xr-x 1 0 0 42942 cg_merge
-rwxr-xr-x 1 0 0 24211 ms_print
-rwxr-xr-x 1 0 0 8531 no_op_client_for_valgrind
-rwxr-xr-x 1 0 0 30823 valgrind
-rwxr-xr-x 1 0 0 18887 valgrind-listener
Jan 15 '10 #1
2 9458
365 100+
if I run the same executable on x86 LINUX machine, it works, my target also x86 based embedded board, there it cannot fine memcheck file, eventhough the file exists in same directory.
Jan 15 '10 #2
365 100+
I tried to use ldd on my embedded target, I copied ldd, but it doesn't show anything.
Jan 15 '10 #3

Sign in to post your reply or Sign up for a free account.

Similar topics

by: gcash | last post by:
I'm doing stuff using COM to automate IE, for some boring repetitive portal tasks I have to do. Anyway, every so often I'll make some sort of error and things will crash, and I'll have to do...
by: Bill Davy | last post by:
I am building a C++ program (main.exe) with VC6 which expects to call the Python DLL. When I start it (under the debugger), I get: "This application has failed to start because python24_d.dll was...
by: camaro77 majau via DotNetMonster.com | last post by:
Sorry by my english but i'm from spain. I have a problem and after search by the web i have know that is due by framework. The message is : setup error "failed to load ressouces from resource...
by: Steve M | last post by:
A few users today received the message "The trust relationship between this workstation and the primary domain failed" on their web browser while using an ASP.NET web app. The problem went away...
by: Roy | last post by:
Hey all, I have a VB App which uses the bundled version of Crystal Reports for VS.NET 2003. It works fine in when I run it using VS *but* when I deploy it anywhere (including the development PC...
by: Dean Slindee | last post by:
The code below is being used to launch WinWord.exe from a VB.NET program. Word launches, but displays this error message: "Word has experienced an error trying to open the file. Try these...
by: ikarlgut | last post by:
We get this error once in a while - every 10 page hits or so... Failed to start monitoring changes to 'bla bla bla'. (Note blah = unc path + file name) We have a file server (win2003) hosting...
by: Vijaya P Krishna | last post by:
Hi, I have a .NET Windows Forms application, written in VB.NET and C#. I am opening a URL from the application using Process.Start(). The URL points to a java servlet running on apache-tomcat....
by: =?Utf-8?B?c25vd2JraWQx?= | last post by:
I have Visual C++ 2005 express edition, I downloaded it from the microsoft website. I am using it for school. I started an assignment in the lab at my school, and for the asssignment I had to...
by: sa6113 | last post by:
I am using this code to connect to a windows machine using paramiko, I have installed sshd on the machine and it works properly: sock.connect((hostname, port)) t = paramiko.Transport(sock)...
by: lllomh | last post by:
Define the method first this.state = { buttonBackgroundColor: 'green', isBlinking: false, // A new status is added to identify whether the button is blinking or not } autoStart=()=>{
by: isladogs | last post by:
The next Access Europe meeting will be on Wednesday 4 Oct 2023 starting at 18:00 UK time (6PM UTC+1) and finishing at about 19:15 (7.15PM) The start time is equivalent to 19:00 (7PM) in Central...
by: Aliciasmith | last post by:
In an age dominated by smartphones, having a mobile app for your business is no longer an option; it's a necessity. Whether you're a startup or an established enterprise, finding the right mobile app...
by: tracyyun | last post by:
Hello everyone, I have a question and would like some advice on network connectivity. I have one computer connected to my router via WiFi, but I have two other computers that I want to be able to...
by: giovanniandrean | last post by:
The energy model is structured as follows and uses excel sheets to give input data: 1-Utility.py contains all the functions needed to calculate the variables and other minor things (mentions...
by: NeoPa | last post by:
Hello everyone. I find myself stuck trying to find the VBA way to get Access to create a PDF of the currently-selected (and open) object (Form or Report). I know it can be done by selecting :...
by: Teri B | last post by:
Hi, I have created a sub-form Roles. In my course form the user selects the roles assigned to the course. 0ne-to-many. One course many roles. Then I created a report based on the Course form and...
by: isladogs | last post by:
The next online meeting of the Access Europe User Group will be on Wednesday 6 Dec 2023 starting at 18:00 UK time (6PM UTC) and finishing at about 19:15 (7.15PM). In this month's session, Mike...
by: GKJR | last post by:
Does anyone have a recommendation to build a standalone application to replace an Access database? I have my bookkeeping software I developed in Access that I would like to make available to other...

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.