By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
455,433 Members | 1,649 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 455,433 IT Pros & Developers. It's quick & easy.

std:lower_bound in gcc-4.3 on SuSE Linux 11.0

P: 3
Hi,

I'm trying to compile (someone else's) code on SuSE 11.0.
It worked fine on SuSE 10.3, but now it's telling me that lower_bound
is not a member of std.

I'm assuming something has changed between the version of gcc
used on SuSE10.3 and gcc-4.3, but I'm unsure. I've been Googling
around for 20 minutes using all sorts of combinations of magic words
(such as you'll find in this post) and found nothing useful. I'll continue,
but if this is a simple/known problem I'd appreciate a pointer in the
right direction.

Many thanks.
Nov 17 '08 #1
Share this Question
Share on Google+
4 Replies


weaknessforcats
Expert Mod 5K+
P: 9,197
Have you #included <algorithm> ?
Nov 17 '08 #2

P: 3
Have you #included <algorithm> ?
No. I was about to ask if it was necessary, but obviously it must be
otherwise you wouldn't have mentioned it.

I'd be interested to know when this was introduced, and to have
more information in general. I shall go and Google for it, but further
hints, suggestions and advice would be welcome.

Thank you.
Nov 17 '08 #3

weaknessforcats
Expert Mod 5K+
P: 9,197
As far as I know <algorithm> was part of C++ 1998 (the current ANSI C++).
Nov 17 '08 #4

P: 3
Hmm - still haven't been able to work out how it compiles in GCC_4.1
given that. Still, problem now solved. Thankyou for you swift and
accurate response.
Nov 19 '08 #5

Post your reply

Sign in to post your reply or Sign up for a free account.