By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
454,465 Members | 1,480 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 454,465 IT Pros & Developers. It's quick & easy.

Serial Programming - Accessing IR device - Device input/output error

P: 6
Hi,

I'm currently trying to develop a IR Remote (TV consumer) listener in C under Linux.

First of all I tried with an old notebook with an integrated IR peripheral (FIR)under Debian (kernel 2.6). All seems to work fine, I can also access directly with
#cat /dev/ttyS1
And my listener (written in C) work pretty fine.

Problems came up with a newer notebook with Ubuntu 8.10.
I set FIR in Bios like the older notebook. But trying to access with cat /dev/ttyS1 raise this error: read: Input/output error
I took immediatly that something lock this device but, how can I see which process lock this resource?

Running my program (a simple non canonical read from the /dev/ttyS1) give me NO data... Seems to be that nothing is coming through the IR port (despite I was trying clicking about an hundred buttons on 3 differents remote controllers :) ).
I tried to unload all modules of irda and I disable UART setting with setserial, but nothing change.

I'm pretty sure that problem came because of "something" who lock this device, but I have no idea how to patch it.

Any suggestions?

Thanks a lot

Sergio
Nov 10 '08 #1
Share this Question
Share on Google+
2 Replies


100+
P: 424
Before looking at your C code, you might want to get your IR port going if you can't access it directly from the console. Try to post on the Linux forum here or some Ubuntu forums.
Nov 10 '08 #2

P: 6
Thanks...
I just cloned this post to the linux forum...
Sorry for the OT
Nov 10 '08 #3

Post your reply

Sign in to post your reply or Sign up for a free account.