469,946 Members | 1,827 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,946 developers. It's quick & easy.

Server-Client application problem

hi all
I'm beginner in CORBA Server-Client application development.

My server- client application was worked well and i have tested it
too.
Due to some Network problem we have rebooted our dedicated server ,
then i restart my corba service, application in the server it started
running without any exception. when the client application tried to
connect with the server it go to wait_to_connect mode and gives
TRANSIENT ERROR

Configuration Details : ( For both the Server and Client Host )
Fedora 6
CORBA =ACE +TAO +5.5.1

The Naming_Service in the server is executed with the following
commands
Naming_Service -ORBEndPoint iiop://server_ip:2809

The Server application
../server -ORBInitRef NameService=corbaloc:iiop:server_ip:2809/
NameService
and the client in my localhost with
../clinet -ORBInitRef NameService=corbaloc:iiop:server_ip:2809/
NameService -ORBDebugLevel 10

the DebugLevel detail for client
TAO (1804|3086403280) - Codeset_Manager_i::init_ccs, Loaded Codeset
translator <UTF8_Latin1_Factory>, ncs = 00010001 tcs = 05010001
TAO (1804|3086403280) - UTF16_BOM_Translator: forceBE 0
TAO (1804|3086403280) Loaded default protocol <IIOP_Factory>
TAO (1804|3086403280) created new ORB <test>
TAO (1804|3086403280) - Transport_Cache_Manager::find_i, no idle
transport is available
TAO (1804|3086403280) - Transport_Cache_Manager::fill_set_i,
current_size = 0, cache_maximum = 512
TAO (1804|3086403280) - IIOP_Connector::make_connection, to <server_ip:
2809which should block
TAO (1804|3086403280) -
Transport_Connector::wait_for_connection_completio n, going to wait for
connection completion on transport[142006576]
TAO (1804|3086403280) - Leader_Follower[142006576]::wait_for_event,
(leader) enter reactor event loop
Caught CORBA::SystemException.
TRANSIENT (IDLmg.org/CORBA/TRANSIENT:1.0)
Destroying ORB <test>

The client waited and gets terminated.

Can any one help me in the issue
Jul 9 '08 #1
1 1961
up
On 9 jul, 04:55, Michael DOUBEZ <michael.dou...@free.frwrote:
vijayakumar a écrit :
[ACE stuff]
Can any one help me in the issue

Yes, ask on comp.soft-sys.ace and fill out the appropriate problem
report form before sending your question.

Look for PROBLEM-REPORT-FORM or BUG-REPORT-FORM files.

--
Michael
Jul 9 '08 #2

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

5 posts views Thread by Grim Reaper | last post: by
2 posts views Thread by Schrodiodo | last post: by
10 posts views Thread by amjad | last post: by
10 posts views Thread by sara | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.