By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
444,190 Members | 1,653 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 444,190 IT Pros & Developers. It's quick & easy.

KDevelop compiling problem

P: 22
I'm using KDevelop 3.3, I've created a new project in c++ as standard hello world program.
Then I placed my c++ source files (>30 files), in "src" dir of project.

Now problem is that my sources are using another header file which I have placed in "src" folder itself.
But KDevelop is not picking up files included in that header file. That header file includes few files from "src/jcc/" folder,

Please help, how to place the included header files or shall i create a static lib of files in "/src/jcc" folder and link them, i dont know how to edit make file in this case.

Thanks in advance
Sep 28 '07 #1
Share this Question
Share on Google+
1 Reply


weaknessforcats
Expert Mod 5K+
P: 9,197
It sounds like you need to set a path to your header files.

When you:
Expand|Select|Wrap|Line Numbers
  1. #include <myheader.h>
  2.  
you are saying the header file is located in a standard place. That is, the header file is located on more or more pre-defined paths.

When you:
Expand|Select|Wrap|Line Numbers
  1. #include "myheader.h"
  2.  
you are saying the header file is located in the present working directory (PWD). Typlically, this is the folder containing your project files. If the header file is not there, the search reverts to the first case for a standard place.

I don't use your tool but there should be a setting for additional include paths for the preprocessor.
Sep 28 '07 #2

Post your reply

Sign in to post your reply or Sign up for a free account.