By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
431,661 Members | 781 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 431,661 IT Pros & Developers. It's quick & easy.

CGI debugging - 500 Internal Server Error

saranjegan
P: 51
Hello,

Am running a CGI script programmed in C in my apache server , the code is throwing some sorts of error with 500 internal server error , from error log i came to know its premature end of script headers when am supposed to troubleshoot it with various resources such as checking the script headers i can' t able to overcome it , i faced same problem with some example program in books too(even hello world), so i made the same program in perl surprisingly it works fine , what might be the reason ?
Aug 6 '07 #1
Share this Question
Share on Google+
5 Replies


numberwhun
Expert Mod 2.5K+
P: 3,503
500 errors are server related and I doubt they are caused by your script. I would investigate as to whether your web server or even your firewall is allowing you access. If you go to a website and get a 500 error than that typically means that someone on the server side has some work to do.

Regards,

Jeff
Aug 6 '07 #2

KevinADC
Expert 2.5K+
P: 4,059
I would ask C questions in the C forum, not the perl forum.
Aug 6 '07 #3

numberwhun
Expert Mod 2.5K+
P: 3,503
He he, I didn't even notice. I just read the word CGI and went from there.

Regards,

Jeff
Aug 6 '07 #4

miller
Expert 100+
P: 1,089
Moving thread from the Perl Forum to the C Forum. The Apache Forum might be a better destination yet.

- MODERATOR
Aug 6 '07 #5

saranjegan
P: 51
Moving thread from the Perl Forum to the C Forum. The Apache Forum might be a better destination yet.

- MODERATOR
I think this is not a perl question , Its more related to CGI program in C not in perl
Aug 7 '07 #6

Post your reply

Sign in to post your reply or Sign up for a free account.