471,585 Members | 1,449 Online
Bytes | Software Development & Data Engineering Community
Post +

Home Posts Topics Members FAQ

Join Bytes to post your question to a community of 471,585 software developers and data experts.

Problem in char " "

Hi,

The charecter/symbol " " writen in a file able to get only in that
system. When the file opened in other system, not able to see that
charecter, insted its viewd as " ? ". So, the special char sets are
different system to system?

How can over come this problem , that to view this symbol " " using
the same kind of editor in any system.

Its very urgent, Sooner reply will be very greatfull.

Thanks,
Sweety

Mar 27 '06 #1
11 1236
you idiot! use html language!!!!!!!!!!!!!!!!

Mar 27 '06 #2
No, the problem in charecter table, my question is the char "" used
any where like *.doc, *.xls any editor, not able to get that on the
same file when open in different system. Able to view only in that
system. How can ensure that the other system supports this char " " .
Any settings will help?? else have to add this "" char in windows
char table..?

Help pls...

Thanks,
Sweety

Mar 27 '06 #3
sweety wrote:
Hi,

The charecter/symbol " " writen in a file able to get only in that
system. When the file opened in other system, not able to see that
charecter, insted its viewd as " ? ". So, the special char sets are
different system to system?
Indeed, character sets are different from system to system. They are
even different on the same system when programs are invoked with
different locale settings.

You'll need to have some knowledge of specifically what character sets
are involved and why the problems are occurring. It sounds like some
sort of Unicode issue.
How can over come this problem , that to view this symbol " " using
the same kind of editor in any system.


Decide on a particular encoding for your files, and then make sure that
your editors all support that encoding, and make sure that they are told
that the file is in that particular encoding.

In my experience UTF-8 is not a bad choice. You do need to take note
that the registered trademark symbol is a multi-byte character in UTF-8
(two bytes, to be specific). It also takes two bytes in a number of
legacy Chinese, Japanese and Korean encodings.

--
Simon.
Mar 27 '06 #4
sweety wrote:
Hi,

The charecter/symbol " " writen in a file able to get only in that
system. When the file opened in other system, not able to see that
charecter, insted its viewd as " ? ". So, the special char sets are
different system to system?

How can over come this problem , that to view this symbol " " using
the same kind of editor in any system.

Its very urgent, Sooner reply will be very greatfull.


This is wrong group to ask in. Post in a group more relavent, perhaps
comp.std.internat or a group devoted to your editor?

Mar 27 '06 #5
Hi Simon,

Thanks for the reply. i'm also thinking on the same way. Would be grt
if you suggest me how i can change the properties for VSS 6.0, encoding
option.

Once again i would like to thank for your reply.

Thanks,
Sweety

Mar 27 '06 #6
Hi,

Further above problem, the scenario is when the file saved in same
system then able to get back.The same file when saved in different
system on same editor and same properties, not able to open in other
systems.

using VS - 7.1, VSS version 6.0

Any help pls....

Thanks,
Sweety

Mar 27 '06 #7
sweety wrote:
Hi,

Further above problem, the scenario is when the file saved in same
system then able to get back.The same file when saved in different
system on same editor and same properties, not able to open in other
systems.

using VS - 7.1, VSS version 6.0

Any help pls....

Thanks,
Sweety


Please read:

<http://cfaj.freeshell.org/google/>
<http://clc-wiki.net/wiki/Introduction_to_comp.lang.c>
<http://www.safalra.com/special/googlegroupsreply/>
<http://en.wikipedia.org/wiki/USENET>
<http://en.wikipedia.org/wiki/Netiquette>

Thanks.

Mar 27 '06 #8
sweety wrote:
Hi,

Further above problem, the scenario is when the file saved in same
system then able to get back.The same file when saved in different
system on same editor and same properties, not able to open in other
systems.

using VS - 7.1, VSS version 6.0

Any help pls....

Thanks,
Sweety

Please read:

<http://cfaj.freeshell.org/google/>
<http://clc-wiki.net/wiki/Introduction_to_comp.lang.c>
<http://www.safalra.com/special/googlegroupsreply/>
<http://en.wikipedia.org/wiki/USENET>
<http://en.wikipedia.org/wiki/Netiquette>

Thanks.

Mar 27 '06 #9
On 2006-03-27, sweety <ur********@gmail.com> wrote:
Hi,

The charecter/symbol " " writen in a file able to get only in that
system. When the file opened in other system, not able to see that
charecter, insted its viewd as " ? ". So, the special char sets are
different system to system?
Yes. Font/character sets change. The same character code can represent a
different character. From your English I guess you are using a
different character set.

How can over come this problem , that to view this symbol " " using
the same kind of editor in any system.
The editor needs to know from which encoding that character code was
selected. It is by no means trivial or easy IMO : at least I've seen
it confuse a lot of people in the past.

Its very urgent, Sooner reply will be very greatfull.

Possibly better to use more standard ascii representation such as (R).
Thanks,
Sweety

--
Debuggers : you know it makes sense.
http://heather.cs.ucdavis.edu/~matlo...g.html#tth_sEc
Mar 27 '06 #10
sp**********@googlemail.com writes:
you idiot! use html language!!!!!!!!!!!!!!!!


Did it ever occur to you that he might not be writing in an HTML (or
SGML, or XML) format?
Mar 27 '06 #11
Me
sweety wrote:
The charecter/symbol " " writen in a file able to get only in that
system. When the file opened in other system, not able to see that
charecter, insted its viewd as " ? ". So, the special char sets are
different system to system? From what I can understand from the vague posts of yours in this thread, it sounds like you're using a source control system and on one
(Windows) computer, when you edit a file in a text editor, it shows up
as (R), but on another computer it shows up as ?. If this is the case,
this is completely irrelevant to C or this newsgroup but I will help
you out anyway. Depending on how lazy the programmer of your text
editor was, there are a few different options:

- Set the encoding when saving the file, make this match up with the
destination.
- Set the encoding when reading the file, make this match up with the
source.
- If neither of the above are available then you have to set the
codepages to both computers to be the same (control panel | regional
options | general tab | set default).
- If even the above doesn't work, then the programmer of both text
editors went out of their way to be extremely evil. In which case, use
a better text editor.
Also, it might be a font issue because if one computer is editing using
a unicode font like "Courier New" and the other computer is using an
old font like "Terminal" which hardcodes the glyphs independent of what
your codepage is set to (and this font in particular doesn't even have
the (R) glyph). If you're on a non-Windows 9x computer, you can check
this out by going to Programs | Accessories | System Tools | Character
Map and seeing if the source and destination fonts are the same. I
doubt this is the case because by default, the ? character is used as a
substitution for encodings that don't map, and this would only come up
if the codepage doesn't map properly but it's something to be aware of.
How can over come this problem , that to view this symbol " " using
the same kind of editor in any system.


You can't.

For close to 100% portability, stick with the charset that the C
standard guarantees is available. For pretty good portability stick to
ASCII. Both of these solutions requires you to use "(R)" sequence
instead of the glyph you're trying to encode. International newsfeeds
like Reuters use this option because it works extremely well.

If you *really* want to use the (R) glyph, people that don't care about
international text usually use one of the latin-1 like encodings (the
Windows-1252 codepage is mostly abused for this purpose because most
people are ignorant of the issue) but if you want to be a good citizen
use UTF-8.

Mar 28 '06 #12

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

2 posts views Thread by Tobias Erbsland | last post: by
4 posts views Thread by John Devereux | last post: by
15 posts views Thread by arnuld | last post: by
20 posts views Thread by liujiaping | last post: by
11 posts views Thread by Lothar Behrens | last post: by
3 posts views Thread by Mahesh | last post: by
reply views Thread by XIAOLAOHU | last post: by
reply views Thread by leo001 | last post: by
reply views Thread by Anwar ali | last post: by

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.