By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
445,852 Members | 2,240 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 445,852 IT Pros & Developers. It's quick & easy.

DLLs

P: n/a
when I try to run my app. on a different computer, I get an error, that DLLs
are missing. How can I make my app. "stand alone"?. I am using VisC++ .Net
Express.
yours
Richard
Jul 23 '05 #1
Share this Question
Share on Google+
7 Replies


P: n/a
This is off-topic here. Try the news group
comp.os.ms-windows.programmer.tools.mfc

There is a compiler/linker option to statically link with MFC.

--
EventStudio 2.5 - http://www.EventHelix.com/EventStudio
Auto Layout and Generate Sequence Diagrams in PDF and MS Word

Jul 23 '05 #2

P: n/a
There are two ways to do this:
The way that does exactly what you ask is to statically link your DLLs.
I'm guessing that the DLLs that are required are MFC or something like
that (not your own).
You have to edit your project settings and look under linker. Here
there should be an option to choose how to link against Microsoft
libraries. I think the current selection will be "Using MFC as a
Dynamic Link Library" (DLL) and you want to change it to "Using MFC as
a Static Link Library". (You should watch out for this:
http://support.microsoft.com/default...b;en-us;194299)

What happens when you do this is all of the code that you use (I
believe it is only the code you use and not the whole DLL) is
incorporated into your EXE. This will bloat the size of your executable
(don't forget, big executables can be slower due to cache misses...).
This is why you should do the second option if possibe:
Package the required DLLs with your app. If you are using an installer
package like InstallShield, this is no problem. Even if you are just
using a zip package you can just include all of the DLLs required in
the same directory as your app.
Either way the error message should say which DLLs are missing (or it
will tell you one at a time - you will have to add the DLL it asks for
and then get another error message to find the next DLL). Just look on
the developer computer for the DLLs and include a copy of them in your
package.

Note that if you are using InstallShield or the like, you should
probably put the files in System32. But check the InstallShield help
for that. (This will make sure that the files are shared and the
space-saving attributes of DLLs are preserved.)

-Kalos

richard pickworth wrote:
when I try to run my app. on a different computer, I get an error, that DLLs
are missing. How can I make my app. "stand alone"?. I am using VisC++ .Net
Express.
yours
Richard


Jul 23 '05 #3

P: n/a
richard pickworth wrote:
when I try to run my app. on a different computer, I get an error, that DLLs
are missing. How can I make my app. "stand alone"?. I am using VisC++ .Net
Express.
yours
Richard


Let me guess: You have compiled it as "Debug" and therefore it links against
Debug-DLLs that are not found on "normal" systems. You can resolve it by
compiling it as "Release"

- Matthias Meixner
Jul 23 '05 #4

P: n/a
actualy, I have tried building as "release" - no joy.
richard
"Matthias Meixner" <ma**************@online.de> wrote in message
news:d7**********@online.de...
richard pickworth wrote:
when I try to run my app. on a different computer, I get an error, that
DLLs
are missing. How can I make my app. "stand alone"?. I am using VisC++
.Net
Express.
yours
Richard


Let me guess: You have compiled it as "Debug" and therefore it links
against
Debug-DLLs that are not found on "normal" systems. You can resolve it by
compiling it as "Release"

- Matthias Meixner

Jul 23 '05 #5

P: n/a
let me guess... You're working on the windows platform?

try using the Depends tool to establish your binary dependencies.
"richard pickworth" <ri***************@btopenworld.com> wrote in message
news:d7*********@nwrdmz02.dmz.ncs.ea.ibs-infra.bt.com...
actualy, I have tried building as "release" - no joy.
richard
"Matthias Meixner" <ma**************@online.de> wrote in message
news:d7**********@online.de...
richard pickworth wrote:
when I try to run my app. on a different computer, I get an error, that
DLLs
are missing. How can I make my app. "stand alone"?. I am using VisC++
.Net
Express.
yours
Richard


Let me guess: You have compiled it as "Debug" and therefore it links
against
Debug-DLLs that are not found on "normal" systems. You can resolve it by
compiling it as "Release"

- Matthias Meixner



Posted Via Usenet.com Premium Usenet Newsgroup Services
----------------------------------------------------------
** SPEED ** RETENTION ** COMPLETION ** ANONYMITY **
----------------------------------------------------------
http://www.usenet.com
Jul 23 '05 #6

P: n/a
On Sat, 4 Jun 2005 15:53:53 +0000 (UTC), "richard pickworth"
<ri***************@btopenworld.com> did courageously avow:
when I try to run my app. on a different computer, I get an error, that DLLs
are missing. How can I make my app. "stand alone"?. I am using VisC++ .Net
Express.
yours
Richard

When you're setting up the project check the box for static linking as
opposed to dynamic linking

Ken Wilson

Amer. Dlx. Tele, Gary Moore LP, LP DC Classic w/P90s,
Jeff Beck Strat, Morgan OM Acoustic,
Rick 360/12, Std. Strat (MIM), Mesa 100 Nomad,
Mesa F-30

"Goodnight Austin, Texas, wherever you are."
Jul 23 '05 #7

P: n/a
Register the DLLs with regsvr32.exe?
yours
Richard
"richard pickworth" <ri***************@btopenworld.com> wrote in message
news:d7*********@nwrdmz02.dmz.ncs.ea.ibs-infra.bt.com...
actualy, I have tried building as "release" - no joy.
richard
"Matthias Meixner" <ma**************@online.de> wrote in message
news:d7**********@online.de...
richard pickworth wrote:
when I try to run my app. on a different computer, I get an error, that
DLLs
are missing. How can I make my app. "stand alone"?. I am using VisC++
.Net
Express.
yours
Richard


Let me guess: You have compiled it as "Debug" and therefore it links
against
Debug-DLLs that are not found on "normal" systems. You can resolve it by
compiling it as "Release"

- Matthias Meixner


Aug 8 '05 #8

This discussion thread is closed

Replies have been disabled for this discussion.