By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
434,826 Members | 2,443 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 434,826 IT Pros & Developers. It's quick & easy.

.NET Smart device application

P: 21
Hi,

I have .NET framwork 1.0 application and it was working fine on Windows CE Device 5.0

Now i upgraded my application from Framwork 1.0 to 2.0
Now when i run my application on Windows CE Device it's not working it's giving me an error

Error 1 Post-deploy error 0x00000001 returned after calling '\Windows\wceload.exe /noui \Windows\System_SR_enu_wm.cab'. Device Connectivity Component


Can any one Help me with this???

Thanks in advance
Dec 18 '08 #1
Share this Question
Share on Google+
4 Replies


nukefusion
Expert 100+
P: 221
Make sure System_SR_enu_wm.cab is available on the device. The version is different for CE 2.0.

You can find the file in C:\Program Files\Microsoft Visual Studio
8\SmartDevices\SDK\CompactFramework\2.0\v2.0\Windo wsCE\Diagnostics
Dec 18 '08 #2

P: 21
Hi,
thanks for your reply.
i checked it already and i have System_SR_ENU_wm.cab file in folder that you specified menas : C:\Program Files\Microsoft Visual Studio 8\SmartDevices\SDK\CompactFramework\2.0\v2.0\Windo wsCE\Diagnostics

And also i try to install it manully in my device. But no luck still same error.

Do you have any idea why this happen?
Dec 19 '08 #3

nukefusion
Expert 100+
P: 221
If you've installed V2 of that file successfully on the device but you're still getting the same error then I'm afraid I'm not sure. Seeing as you've upgraded to version 2.0 of the framework and now the error is occurring I would have thought a file version mismatch was the most likely culprit.
Dec 19 '08 #4

Plater
Expert 5K+
P: 7,872
You have to make sure your device has CF2.0 installed as well, probably inside its image file. It's been my experience then "installing" cf2 after the device has booted up...that another reboot will wipe out the install. So its only good for the booted session that you installed it.
Dec 19 '08 #5

Post your reply

Sign in to post your reply or Sign up for a free account.