467,879 Members | 1,172 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 467,879 developers. It's quick & easy.

Enterprise library: The current build operation failed

It looks like that there is very little resource about the Enterprise
Library on the Web. I know it is documented at msdn, but I haven't
found a whole lot sample codes.

I was trying out the ExceptionHandling block. So I followed the
example at

http://www.codersource.net/csharp_ex...e_library.aspx

When I debug it, I get this:

Microsoft.Practices.EnterpriseLibrary.ExceptionHan dling.ExceptionHandlingException
was unhandled by user code
Message="The current build operation (build key Build
Key[Microsoft.Practices.EnterpriseLibrary.ExceptionHan dling.ExceptionPolicyImpl,
General Exception]) failed: Object reference not set to an instance of
an object. (Strategy type
Microsoft.Practices.EnterpriseLibrary.Common.Confi guration.ObjectBuilder.ConfiguredObjectStrategy,
index 2)"
Source="Microsoft.Practices.EnterpriseLibrary.Exce ptionHandling"

I googled and found this:

http://groups.google.com/group/micro...PolicyImpl%2C#

Where Jeff Win, who also seems to be active in this csharp group, says
that the problems is that

Microsoft.Practices.EnterpriseLibrary.ExceptionHan dling.WCF,
Version=4.0.0.0,

was not included in the bin folder.

But, I do have it in my bin folder. However, I do notice that the
version says 1 [Neutral], instead of 4. I don't know why though, I
did install Enterprise Library 4.0 and added those dll's into my bin
folder of my website.

Any idea how to combat this error?

Sep 18 '08 #1
  • viewed: 6024
Share:
1 Reply
On Sep 18, 3:02*pm, Author <gnewsgr...@gmail.comwrote:
It looks like that there is very little resource about the Enterprise
Library on the Web. *I know it is documented at msdn, but I haven't
found a whole lot sample codes.

I was trying out the ExceptionHandling block. *So I followed the
example at

http://www.codersource.net/csharp_ex...terprise_libra...

When I debug it, I get this:

Microsoft.Practices.EnterpriseLibrary.ExceptionHan dling.ExceptionHandlingException
was unhandled by user code
* Message="The current build operation (build key Build
Key[Microsoft.Practices.EnterpriseLibrary.ExceptionHan dling.ExceptionPolicyImpl,
General Exception]) failed: Object reference not set to an instance of
an object. (Strategy type
Microsoft.Practices.EnterpriseLibrary.Common.Confi guration.ObjectBuilder.ConfiguredObjectStrategy,
index 2)"
* Source="Microsoft.Practices.EnterpriseLibrary.Exce ptionHandling"

I googled and found this:

http://groups.google.com/group/micro...general/browse...

Where Jeff Win, who also seems to be active in this csharp group, says
that the problems is that

Microsoft.Practices.EnterpriseLibrary.ExceptionHan dling.WCF,
Version=4.0.0.0,

was not included in the bin folder.

But, I do have it in my bin folder. *However, I do notice that the
version says 1 [Neutral], instead of 4. *I don't know why though, I
did install Enterprise Library 4.0 and added those dll's into my bin
folder of my website.

Any idea how to combat this error?
BTW, the exception occurs at the following line:

bool rethrow = ExceptionPolicy.HandleException(exception, "Divide By
Zero");
Sep 18 '08 #2

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

4 posts views Thread by P.Kienzle | last post: by
reply views Thread by ritesh.singhal | last post: by
3 posts views Thread by bungle | last post: by
reply views Thread by =?Utf-8?B?UG9sbHkgQW5uYQ==?= | last post: by
reply views Thread by MrMoon | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.