471,335 Members | 1,523 Online
Bytes | Software Development & Data Engineering Community
Post +

Home Posts Topics Members FAQ

Join Bytes to post your question to a community of 471,335 software developers and data experts.

COM registration problem.

Environment:
Vista 64 bit
VS.Net 2008 SP2 with two configurations enabled: x86 and x64.

Im building a solution with two projects: Some.exe and SystemAlicja.dll
with register to COM interop enabled on it.

When building SystemAlicja.dll on x86 configuration the build process
runs sucessfully but when im creating a setup project (x86) later I have a
message:

WARNING: Unable to create registration information for file named
'SystemAlicja.tlb'

When building SystemAlicja.dll on x64 configuration the build process
fails with message:

error MSB3097: File "C:\Alicja\SystemAlicja\bin\x64\Debug\SystemAlicja .dll"
is not a valid assembly"

When I disable COM register on SystemAlicja.dll all (build and setup
project)
runs OK on both configurations.

What do I have to do to force it works properly?

Sep 8 '08 #1
0 1045

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

1 post views Thread by Ashok K Kumar | last post: by
2 posts views Thread by blantz | last post: by
reply views Thread by rosydwin | last post: by

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.