By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
434,728 Members | 2,488 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 434,728 IT Pros & Developers. It's quick & easy.

how do I remove asp.net web configuration?

P: n/a
I added security using the asp.net web site configuration tool and now I
want to remove it. I tried removing default provider via the asp.net
settings but it won't let me. It gives an error stating the provider name
must be at least 1 character long.

I want to use authentication but the simplified version of storing user
names and passwords in the web.config.

thanks
Aug 29 '07 #1
Share this Question
Share on Google+
5 Replies


P: n/a
Have you tried editing the web.config file in NotePad?

--
HTH,

Kevin Spencer
Microsoft MVP

DSI PrintManager, Miradyne Component Libraries:
http://www.miradyne.net

"Coaster" <Co*****@Coaster.netwrote in message
news:%2****************@TK2MSFTNGP03.phx.gbl...
>I added security using the asp.net web site configuration tool and now I
want to remove it. I tried removing default provider via the asp.net
settings but it won't let me. It gives an error stating the provider name
must be at least 1 character long.

I want to use authentication but the simplified version of storing user
names and passwords in the web.config.

thanks

Aug 29 '07 #2

P: n/a
Hi,

"Coaster" <Co*****@Coaster.netwrote in message
news:%2****************@TK2MSFTNGP03.phx.gbl...
>I added security using the asp.net web site configuration tool and now I
want to remove it. I tried removing default provider via the asp.net
settings but it won't let me. It gives an error stating the provider name
must be at least 1 character long.

I want to use authentication but the simplified version of storing user
names and passwords in the web.config.
You should post this kind of questions in the ASP.net NG.
Aug 29 '07 #3

P: n/a
I removed add security related settings from the web.config and it worked as
expected . Then I added the forms authentication and credentials directing
it to a login.aspx page that should direct it to a default.aspx but instead
I get an error message stating
Default Membership Provider must be specified

Its like it thinks its using the old provider. I'm don't know where its
getting this from

This is what I have in web.config
<authorization>

<deny users="?"/>

</authorization>

<authentication mode="Forms">

<forms loginUrl="Login.aspx">

<credentials>

<user name="joe" password="Smith" />

<user name="azam" password="hello" />

</credentials>

</forms>

</authentication>

"Kevin Spencer" <un**********@nothinks.comwrote in message
news:uY**************@TK2MSFTNGP02.phx.gbl...
Have you tried editing the web.config file in NotePad?

--
HTH,

Kevin Spencer
Microsoft MVP

DSI PrintManager, Miradyne Component Libraries:
http://www.miradyne.net

"Coaster" <Co*****@Coaster.netwrote in message
news:%2****************@TK2MSFTNGP03.phx.gbl...
>>I added security using the asp.net web site configuration tool and now I
want to remove it. I tried removing default provider via the asp.net
settings but it won't let me. It gives an error stating the provider name
must be at least 1 character long.

I want to use authentication but the simplified version of storing user
names and passwords in the web.config.

thanks


Aug 29 '07 #4

P: n/a
I got it, the login control is looking for the provider. I removed that and
replaced with some text boxes and forms auth.
"Coaster" <Co*****@Coaster.netwrote in message
news:%2****************@TK2MSFTNGP05.phx.gbl...
>I removed add security related settings from the web.config and it worked
as expected . Then I added the forms authentication and credentials
directing it to a login.aspx page that should direct it to a default.aspx
but instead I get an error message stating
Default Membership Provider must be specified

Its like it thinks its using the old provider. I'm don't know where its
getting this from

This is what I have in web.config
<authorization>

<deny users="?"/>

</authorization>

<authentication mode="Forms">

<forms loginUrl="Login.aspx">

<credentials>

<user name="joe" password="Smith" />

<user name="azam" password="hello" />

</credentials>

</forms>

</authentication>

"Kevin Spencer" <un**********@nothinks.comwrote in message
news:uY**************@TK2MSFTNGP02.phx.gbl...
>Have you tried editing the web.config file in NotePad?

--
HTH,

Kevin Spencer
Microsoft MVP

DSI PrintManager, Miradyne Component Libraries:
http://www.miradyne.net

"Coaster" <Co*****@Coaster.netwrote in message
news:%2****************@TK2MSFTNGP03.phx.gbl...
>>>I added security using the asp.net web site configuration tool and now I
want to remove it. I tried removing default provider via the asp.net
settings but it won't let me. It gives an error stating the provider name
must be at least 1 character long.

I want to use authentication but the simplified version of storing user
names and passwords in the web.config.

thanks



Aug 30 '07 #5

P: n/a
You might want to read the following article, to help you go further with
it:

http://www.15seconds.com/issue/020220.htm

--
HTH,

Kevin Spencer
Microsoft MVP

DSI PrintManager, Miradyne Component Libraries:
http://www.miradyne.net

"Coaster" <Co*****@Coaster.netwrote in message
news:%2***************@TK2MSFTNGP05.phx.gbl...
>I got it, the login control is looking for the provider. I removed that and
replaced with some text boxes and forms auth.
"Coaster" <Co*****@Coaster.netwrote in message
news:%2****************@TK2MSFTNGP05.phx.gbl...
>>I removed add security related settings from the web.config and it worked
as expected . Then I added the forms authentication and credentials
directing it to a login.aspx page that should direct it to a default.aspx
but instead I get an error message stating
Default Membership Provider must be specified

Its like it thinks its using the old provider. I'm don't know where its
getting this from

This is what I have in web.config
<authorization>

<deny users="?"/>

</authorization>

<authentication mode="Forms">

<forms loginUrl="Login.aspx">

<credentials>

<user name="joe" password="Smith" />

<user name="azam" password="hello" />

</credentials>

</forms>

</authentication>

"Kevin Spencer" <un**********@nothinks.comwrote in message
news:uY**************@TK2MSFTNGP02.phx.gbl...
>>Have you tried editing the web.config file in NotePad?

--
HTH,

Kevin Spencer
Microsoft MVP

DSI PrintManager, Miradyne Component Libraries:
http://www.miradyne.net

"Coaster" <Co*****@Coaster.netwrote in message
news:%2****************@TK2MSFTNGP03.phx.gbl.. .
I added security using the asp.net web site configuration tool and now I
want to remove it. I tried removing default provider via the asp.net
settings but it won't let me. It gives an error stating the provider
name must be at least 1 character long.

I want to use authentication but the simplified version of storing user
names and passwords in the web.config.

thanks



Aug 30 '07 #6

This discussion thread is closed

Replies have been disabled for this discussion.