By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
459,223 Members | 1,434 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 459,223 IT Pros & Developers. It's quick & easy.

fxcop problem

P: n/a
Hi,

Need some advice on debugging the static code analysis (fxcop) service
in vs2005 teamsenter. In our solution any fxcop fault is configured to
result in a compiler error. On all development computers our source
code compiles \ builds without any problem.

However, on the designated building computer when compiling the source
we get roughtly 30 fxcop related errors of type CA1823. Obviously
using vs2005 ts there aswell. Viewing the output window in vs2005 the
commands issued by vs2005 on the two computers are alike.

The source code is obviously the same on the two computer, therefore I
can only assume that it must be an environmentall difference that
causing the problem. Can anyone give any clues to what files \
settings \ registry that the builtin fxcop in vs2005 ts uses when
checking the code?

Appreciate any input on this matter.

Cheers

Aug 17 '07 #1
Share this Question
Share on Google+
2 Replies


P: n/a
Is the build machine the same version of vs2005 as the dev machines?
SP1 fixed some false positives with CA1823.
Aug 17 '07 #2

P: n/a
On 17 Aug, 17:47, Graeme Bradbury <graeme.bradb...@bcs.org.ukwrote:
Is the build machine the same version of vs2005 as the dev machines?
SP1 fixed some false positives with CA1823.
Adding sp1 solved it. Cheers.

Aug 21 '07 #3

This discussion thread is closed

Replies have been disabled for this discussion.