By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
425,749 Members | 1,615 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 425,749 IT Pros & Developers. It's quick & easy.

RewriterRule not working for alias domain name

P: n/a
Hi

We are working on a multilingual website. it has five URL (one
original and four alias) for all the five languages. we are using
RewriterRule in web.config to rewrite the Url. All this working fine
on my local machine but when we have upload it on live we are facing a
problem. that RewriteRule doesn't working for the alias name. it means
when we request any page with alias name RewriterRule not works
properly

Example :

main website is Webcarhire.com
and alias is webcarhire.fr

when I request a page webcarhire.com/contactus.htm - the RewriterRule
works fine

but

when i request a page webcarhire.fr/contactus.htm - the RewriterRule
is not working

Note : I have assign the worker process to .htm and .html page in ISS
and also
I have add following rule in web.config
<RewriterConfig>
<Rules>
<RewriterRule>
<LookFor>[^\.fr].+\.htm</LookFor>
<SendTo>~/BlankPage.aspx</SendTo>
</RewriterRule>
</Rules>
</RewriterConfig>


Please let me know if any one have solved this problem.

May 9 '07 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.