By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
424,837 Members | 1,813 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 424,837 IT Pros & Developers. It's quick & easy.

ReportViewer: Non-embedded subreports

P: n/a
Hi,

I'm having an issue with VS .NET 2k5.

I have a master report that is the parent of several subreports (the
report got too big to keep it all in the same report). For a while
this worked fine, the BuildAction property of each was set to Embedded
Resource, and the subreport name was all I needed to change in the
master report for each to be displayed (I handled the
SubreportProcessing event to deal with data sources).

Now my application is getting to the point where I need to display
different types of reports, which is to say that not all of my
subreports will be used. Because they're starting to take up a lot of
memory, I have declined any BuildActions on each, and set them all to
be copied into a folder beneath the build directory. Setting the
ReportPath property of the ReportViewer control is all I need to do to
get the master report to load properly.

However, in the master report there is no way for me to give a path to
the subreports. If, for the ReportName property of the subreport
control in the master report, I enter "<Folder>\<SubreportName>" with
or without the .rdlc file extension, I get an error for including the
"\" character in the ReportName property. If I choose the report name
from the drop down box, I get an "error: subreport could not be shown"
line of text where the subreport should be located on the main report.

Furthermore, I know this is not something to do with an excluded data
source, because I've tried it with a completely blank subreport and a
master report that refers to only it, and I still get the error.

I could sure use a hand on what to do next!! Thanks,

-Brandon

Apr 25 '07 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.