By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
458,114 Members | 1,574 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 458,114 IT Pros & Developers. It's quick & easy.

Urgent!! DataGrid OnSortCommand not fire if UserControl is added in the ASPX

P: n/a
Dear All Experts

I faced a problem, I had developed a UserControl (just a simple display the
website logo), and added into a ASPX page.
Inside the ASPX, i have a DataGrid control, and it contains OnSortCommand
defined.
However, when I try to sorting the datagrid, no any event is fired up. I
found that if I removed the UserControl from the ASPX page, the
OnSortCommand is executed, if the UserControl is added backed into the ASPX,
the OnSortCommand will not fired up again....

Did you face this problem before and how to solve it?

Thanks
Mar 16 '07 #1
Share this Question
Share on Google+
1 Reply


P: n/a
I found out the problem
Thanks

"榮少" <榮少@艾雞堡.甘撰寫於郵件新聞:%2****************@T K2MSFTNGP06.phx.gbl...
Dear All Experts

I faced a problem, I had developed a UserControl (just a simple display
the website logo), and added into a ASPX page.
Inside the ASPX, i have a DataGrid control, and it contains OnSortCommand
defined.
However, when I try to sorting the datagrid, no any event is fired up. I
found that if I removed the UserControl from the ASPX page, the
OnSortCommand is executed, if the UserControl is added backed into the
ASPX, the OnSortCommand will not fired up again....

Did you face this problem before and how to solve it?

Thanks


Mar 16 '07 #2

This discussion thread is closed

Replies have been disabled for this discussion.