469,922 Members | 2,190 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,922 developers. It's quick & easy.

setup project in VS 2003

I created a setup project in VS 2003 to deploy a windows application.
I'm able to run that installer in any windows xp m/c, when I try to install
the setip in a vista m/c, it goes all the way and hangs at the end.

I tried to create a small setup project in vs 2005 and I was able to run the
setup in vista machine.
So I'm wondering if there are any patch / fix for VS 2003 to run in vista?

Thanks for your help.

John
Mar 7 '07 #1
3 1493
Do you have any custom actions in your VS 2003 setup?
--
Phil Wilson
[Microsoft MVP - Windows Installer]

"John" <aj******@hotmail.comwrote in message
news:uW**************@TK2MSFTNGP05.phx.gbl...
>I created a setup project in VS 2003 to deploy a windows application.
I'm able to run that installer in any windows xp m/c, when I try to
install
the setip in a vista m/c, it goes all the way and hangs at the end.

I tried to create a small setup project in vs 2005 and I was able to run
the
setup in vista machine.
So I'm wondering if there are any patch / fix for VS 2003 to run in vista?

Thanks for your help.

John


Mar 7 '07 #2
Just a Primary Output from the Project.

John britto

"Phil Wilson" <ph*********@wonderware.something.comwrote in message
news:%2****************@TK2MSFTNGP05.phx.gbl...
Do you have any custom actions in your VS 2003 setup?
--
Phil Wilson
[Microsoft MVP - Windows Installer]

"John" <aj******@hotmail.comwrote in message
news:uW**************@TK2MSFTNGP05.phx.gbl...
>>I created a setup project in VS 2003 to deploy a windows application.
I'm able to run that installer in any windows xp m/c, when I try to
install
the setip in a vista m/c, it goes all the way and hangs at the end.

I tried to create a small setup project in vs 2005 and I was able to run
the
setup in vista machine.
So I'm wondering if there are any patch / fix for VS 2003 to run in
vista?

Thanks for your help.

John



Mar 7 '07 #3
That will break it. Custom actions on Vista run with standard user token and
consequently break. The recommended solution is to set the
msidbCustomActionTypeNoImpersonate bit in the custom action type, but Visual
Studio has no IDE support for that.
--
Phil Wilson
[Microsoft MVP Windows Installer]

"John" <aj******@hotmail.comwrote in message
news:ek**************@TK2MSFTNGP03.phx.gbl...
Just a Primary Output from the Project.

John britto

"Phil Wilson" <ph*********@wonderware.something.comwrote in message
news:%2****************@TK2MSFTNGP05.phx.gbl...
>Do you have any custom actions in your VS 2003 setup?
--
Phil Wilson
[Microsoft MVP - Windows Installer]

"John" <aj******@hotmail.comwrote in message
news:uW**************@TK2MSFTNGP05.phx.gbl...
>>>I created a setup project in VS 2003 to deploy a windows application.
I'm able to run that installer in any windows xp m/c, when I try to
install
the setip in a vista m/c, it goes all the way and hangs at the end.

I tried to create a small setup project in vs 2005 and I was able to run
the
setup in vista machine.
So I'm wondering if there are any patch / fix for VS 2003 to run in
vista?

Thanks for your help.

John




Mar 8 '07 #4

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

reply views Thread by joe.bockskopf | last post: by
1 post views Thread by Luther Miller | last post: by
2 posts views Thread by =?Utf-8?B?Vi5DaG9ja2FsaW5nYW0u?= | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.