By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
428,659 Members | 940 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 428,659 IT Pros & Developers. It's quick & easy.

Problema copia file

P: n/a
Ale
Buongiorno a tutti,
mi trovo davanti a un problema, io ho un web services nel quale ho definito
una funzione che lancia un eseguibile sul server con lo scopo di prelevare
dei file da una cartella, elaborarli ed inserirne il risultato in un
database, dopo di che provvede a spostare file di origine in una cartella
storico. Il problema è questo i file non vengono spostati nella cartella di
destinazione " E:/MioApplicativo/Storico File/" ma in
"C:/Windows/Sytem32/Inetsrv/Storico File" qualcuno sa aiutarmi?
L'utenza con il quale il mio processo viene lanciato è NT AUTHORITY/SERVIZIO
DI RETE ed io ho provveduto a dare i privilegi necessari sia alla cartella
da cui legge che a quella in cui scrive.

Grazie a tutti in anticipo

Alessandro
Feb 5 '07 #1
Share this Question
Share on Google+
2 Replies


P: n/a
Prova ad usare Server.MapPath("~/StoricoFile");

Chris

On 5 feb, 09:59, "Ale" <a.eus...@ecconsulting.it-nospam-wrote:
Buongiorno a tutti,
mi trovo davanti a un problema, io ho un web services nel quale ho definito
una funzione che lancia un eseguibile sul server con lo scopo di prelevare
dei file da una cartella, elaborarli ed inserirne il risultato in un
database, dopo di che provvede a spostare file di origine in una cartella
storico. Il problema è questo i file non vengono spostati nella cartella di
destinazione " E:/MioApplicativo/Storico File/" ma in
"C:/Windows/Sytem32/Inetsrv/Storico File" qualcuno sa aiutarmi?
L'utenza con il quale il mio processo viene lanciato è NT AUTHORITY/SERVIZIO
DI RETE ed io ho provveduto a dare i privilegi necessari sia alla cartella
da cui legge che a quella in cui scrive.

Grazie a tutti in anticipo

Alessandro

Feb 5 '07 #2

P: n/a
Ale
Non posso perchè il processo lanciato dal web services è una windows app e
quindi non ho MapPath... provo con Application.StartupPath, ma nn credo mi
restituisca una stringa diversa da quella che gia' gli passo.
In ogni caso grazie.

>>Prova ad usare Server.MapPath("~/StoricoFile");

Chris


Feb 5 '07 #3

This discussion thread is closed

Replies have been disabled for this discussion.