By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
455,337 Members | 1,323 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 455,337 IT Pros & Developers. It's quick & easy.

Weird problem with treeview tooltips - Expert input required :0) please

P: n/a
Hi,
I have a treeview which has some nodes whose text are too long to
display, so, when i hover my mouse over the node a tooltip appears
showing all the text, and then disappears almost immediately. If i move

my mouse across the node it flashes on and off (something seems to be
cancelling it?)

If i turn my main form's transparencykey to nothing, the problem goes
away.

If i look in spy++, i seem to find TTM_POP messages appearing when the
transparencykey is set, but no TTM_POP when it is not set.

Help!
James.

Jan 24 '07 #1
Share this Question
Share on Google+
1 Reply


P: n/a

You can replicate this behaviour by
1) creating a new windows application
2) set Form1.TransparencyKey to the same as Form1.BackColor
3) Add a treeview to the form
4) Add a node to TreeView1 whose text is too long (i used
'whyisthishappeningwhyisthishappeningwhyisthishapp eningwhywhywhy')
5) run it and hover your mouse over the node.

Cheers,
James

On 24 Jan, 12:23, "pigeonrandle" <pigeonran...@hotmail.comwrote:
Hi,
I have a treeview which has some nodes whose text are too long to
display, so, when i hover my mouse over the node a tooltip appears
showing all the text, and then disappears almost immediately. If i move

my mouse across the node it flashes on and off (something seems to be
cancelling it?)

If i turn my main form's transparencykey to nothing, the problem goes
away.

If i look in spy++, i seem to find TTM_POP messages appearing when the
transparencykey is set, but no TTM_POP when it is not set.

Help!
James.
Jan 24 '07 #2

This discussion thread is closed

Replies have been disabled for this discussion.