By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
443,693 Members | 1,936 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 443,693 IT Pros & Developers. It's quick & easy.

system.directoryservices question

P: n/a
Hi all

I have inherited a sharepoint web part from my predecessor that is
displaying an issue. It calls FindAll() to locate a specific security
group, and then enumerates through the group to retrieve the user's
display names and email addresses.

*Very* intermittently this web part will throw an exception - either
"System.Runtime.InteropServices.COMException (0x8007202A): The server
is not operational" or, sometimes, "The authentication mechanism is
unknown". When I say intermittently, I mean very intermittently - it is
fine 99% of the time. There doesn't seem to be any pattern to the
errors (have been using perfmon and netstat to watch server load when I
see it), and we can go many days without seeing it at all.

I have read online about a bug - you're not supposed to use FindOne()
with .NET 1.1 as it causes connection issues. Does anyone know about
such a problem with FindAll()?

I am really hoping someone can help, this is proving very difficult to
fix as it is so irregular and have little experience with this API.

Many TIA, Rich

Dec 17 '06 #1
Share this Question
Share on Google+
2 Replies


P: n/a
Just a suggestion. You should try Sharepoint Service 3.0 because it is
ASP.NET 2.0 web part compatible as I understand and it is still free.

chanmm

<ri****************@eshareuk.comwrote in message
news:11*********************@16g2000cwy.googlegrou ps.com...
Hi all

I have inherited a sharepoint web part from my predecessor that is
displaying an issue. It calls FindAll() to locate a specific security
group, and then enumerates through the group to retrieve the user's
display names and email addresses.

*Very* intermittently this web part will throw an exception - either
"System.Runtime.InteropServices.COMException (0x8007202A): The server
is not operational" or, sometimes, "The authentication mechanism is
unknown". When I say intermittently, I mean very intermittently - it is
fine 99% of the time. There doesn't seem to be any pattern to the
errors (have been using perfmon and netstat to watch server load when I
see it), and we can go many days without seeing it at all.

I have read online about a bug - you're not supposed to use FindOne()
with .NET 1.1 as it causes connection issues. Does anyone know about
such a problem with FindAll()?

I am really hoping someone can help, this is proving very difficult to
fix as it is so irregular and have little experience with this API.

Many TIA, Rich
Dec 18 '06 #2

P: n/a
Thanks but moving my production portals over to a different framework
is not really appealing compared to just fixing the web part :)

I have disposed and closed all the objects I can see in the
directorysearcher method and haven't seen an error since... Fingers
crossed...

Dec 18 '06 #3

This discussion thread is closed

Replies have been disabled for this discussion.