By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
434,894 Members | 1,942 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 434,894 IT Pros & Developers. It's quick & easy.

Can C# Express 2005 target .Net 1?

P: n/a
I want my app to be able to run on PCs without requiring a .Net 2
download.

Can C# Express 2005 be set to create applications that work with .Net 1
even if it requires .Net 2 to run itself?

Oct 2 '06 #1
Share this Question
Share on Google+
5 Replies


P: n/a
Can assemblies with with 2005 run on Framework v1.0? No.

"pkirk25" <pa*****@kirks.netwrote in message
news:11**********************@e3g2000cwe.googlegro ups.com...
>I want my app to be able to run on PCs without requiring a .Net 2
download.

Can C# Express 2005 be set to create applications that work with .Net 1
even if it requires .Net 2 to run itself?

Oct 2 '06 #2

P: n/a
Hello pkirk25,

In spite of which edition of VS 2005 u use, it only assigned for .NET 2.0

pI want my app to be able to run on PCs without requiring a .Net 2
pdownload.
p>
pCan C# Express 2005 be set to create applications that work with .Net
p1 even if it requires .Net 2 to run itself?
p>
---
WBR,
Michael Nemtsev :: blog: http://spaces.live.com/laflour

"At times one remains faithful to a cause only because its opponents do not
cease to be insipid." (c) Friedrich Nietzsche
Oct 2 '06 #3

P: n/a
pkirk25 <pa*****@kirks.netwrote:
I want my app to be able to run on PCs without requiring a .Net 2
download.

Can C# Express 2005 be set to create applications that work with .Net 1
even if it requires .Net 2 to run itself?
Yess, it can. See
http://www.codeplex.com/Wiki/View.as...jectName=MSBee

At least, I don't see why it shouldn't work - I expect it's usually
used with Visual Studio 2005 Professional and higher, but it's worth
trying with C# Express.

--
Jon Skeet - <sk***@pobox.com>
http://www.pobox.com/~skeet Blog: http://www.msmvps.com/jon.skeet
If replying to the group, please do not mail me too
Oct 2 '06 #4

P: n/a

Jon Skeet [ C# MVP ] wrote:
http://www.codeplex.com/Wiki/View.as...jectName=MSBee
Thanks for link!

My target is a little application that generates auction house trends
and buy-lists for World of Warcraft.

I would guess all of the potential users have broadband.

I wonder what percentage of potential users will be put off by needing
to dwonload 15MB from MS? Or is .Net 2 already widely used?

Oct 2 '06 #5

P: n/a
The 2.0 Framework is not installed into Windows by default. It is listed as
an optional download in Windows Update.
"pkirk25" <pa*****@kirks.netwrote in message
news:11*********************@b28g2000cwb.googlegro ups.com...
>
Jon Skeet [ C# MVP ] wrote:
>http://www.codeplex.com/Wiki/View.as...jectName=MSBee

Thanks for link!

My target is a little application that generates auction house trends
and buy-lists for World of Warcraft.

I would guess all of the potential users have broadband.

I wonder what percentage of potential users will be put off by needing
to dwonload 15MB from MS? Or is .Net 2 already widely used?

Oct 3 '06 #6

This discussion thread is closed

Replies have been disabled for this discussion.