By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
446,156 Members | 962 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 446,156 IT Pros & Developers. It's quick & easy.

wsdl question

P: n/a
hs
Hi
I have a webservice i created using visual studio 2003, and i want to
expose/deploy it to the internet.
my problem is when i open up the wsdl, it still references an internal
machine

how do i change this

http://192.159.100.81/MyWebService/Service1.asmx

to

http://mywebsite.com/MyWebService/Service1.asmx

in my visual studio project

thanks


Jul 14 '06 #1
Share this Question
Share on Google+
6 Replies


P: n/a
Hi
I have a webservice i created using visual studio 2003, and i want to
expose/deploy it to the internet.
my problem is when i open up the wsdl, it still references an internal
machine

how do i change this

http://192.159.100.81/MyWebService/Service1.asmx

to

http://mywebsite.com/MyWebService/Service1.asmx

in my visual studio project

thanks
If you set the "URL behavior" to Dynamic, then you will get a line in
the web.config/app.config where you can define the URL.
Regardless of this, you can always set the URL from the code. See the
Url property of the webservice class.

Hans Kesting
Jul 14 '06 #2

P: n/a
hs
Hi Hans
thanks for your help. I tried what you have suggested but my wsdl still has
this reference

<service name="Service1">
<port name="Service1Soap" binding="s0:Service1Soap">
<soap:address location=http://192.159.100.81/MyWebService/Service1.asmx />
</port>
</service>

'192.159.100.81' should be replaced with 'my.website.com' (for example).

any other ideas
thanks (much appreciated)
hs
"Hans Kesting" <ne***********@spamgourmet.comwrote in message
news:mn***********************@spamgourmet.com...
>Hi
I have a webservice i created using visual studio 2003, and i want to
expose/deploy it to the internet.
my problem is when i open up the wsdl, it still references an internal
machine

how do i change this

http://192.159.100.81/MyWebService/Service1.asmx

to

http://mywebsite.com/MyWebService/Service1.asmx

in my visual studio project

thanks

If you set the "URL behavior" to Dynamic, then you will get a line in the
web.config/app.config where you can define the URL.
Regardless of this, you can always set the URL from the code. See the Url
property of the webservice class.

Hans Kesting


Jul 14 '06 #3

P: n/a
hs,
As was described, the Url property of your proxy class would override this.
Just set the Url property before making any method calls.
Peter

--
Co-founder, Eggheadcafe.com developer portal:
http://www.eggheadcafe.com
UnBlog:
http://petesbloggerama.blogspot.com


"hs" wrote:
Hi Hans
thanks for your help. I tried what you have suggested but my wsdl still has
this reference

<service name="Service1">
<port name="Service1Soap" binding="s0:Service1Soap">
<soap:address location=http://192.159.100.81/MyWebService/Service1.asmx />
</port>
</service>

'192.159.100.81' should be replaced with 'my.website.com' (for example).

any other ideas
thanks (much appreciated)
hs
"Hans Kesting" <ne***********@spamgourmet.comwrote in message
news:mn***********************@spamgourmet.com...
Hi
I have a webservice i created using visual studio 2003, and i want to
expose/deploy it to the internet.
my problem is when i open up the wsdl, it still references an internal
machine

how do i change this

http://192.159.100.81/MyWebService/Service1.asmx

to

http://mywebsite.com/MyWebService/Service1.asmx

in my visual studio project

thanks
If you set the "URL behavior" to Dynamic, then you will get a line in the
web.config/app.config where you can define the URL.
Regardless of this, you can always set the URL from the code. See the Url
property of the webservice class.

Hans Kesting


Jul 14 '06 #4

P: n/a
hs
Thanks for your input but i'm still lost.

My situation is as follows.
I have an asp.net webservice running on a development machine (created using
vs 2003).

the IT guys at my work place have exposed this development
machine/webservice to the web using microsoft ISA server 2004 (using a web
publishing rule).

however when i look at the wsdl for mywebservice, it still
refers to the local machine

<soap:address location=http://192.159.100.81/MyWebService/Service1.asmx />

all i'm trying to do is change this reference to

<soap:address
location=http://www.ourcompany.com/hsfolder/MyWebService/Service1.asmx />
Maybe my webservice needs to be in release mode or something. i'm a newbie
to all this thanks


"Peter Bromberg [C# MVP]" <pb*******@yahoo.nospammin.comwrote in message
news:1B**********************************@microsof t.com...
hs,
As was described, the Url property of your proxy class would override
this.
Just set the Url property before making any method calls.
Peter

--
Co-founder, Eggheadcafe.com developer portal:
http://www.eggheadcafe.com
UnBlog:
http://petesbloggerama.blogspot.com


"hs" wrote:
>Hi Hans
thanks for your help. I tried what you have suggested but my wsdl still
has
this reference

<service name="Service1">
<port name="Service1Soap" binding="s0:Service1Soap">
<soap:address location=http://192.159.100.81/MyWebService/Service1.asmx
/>
</port>
</service>

'192.159.100.81' should be replaced with 'my.website.com' (for example).

any other ideas
thanks (much appreciated)
hs
"Hans Kesting" <ne***********@spamgourmet.comwrote in message
news:mn***********************@spamgourmet.com. ..
>Hi
I have a webservice i created using visual studio 2003, and i want to
expose/deploy it to the internet.
my problem is when i open up the wsdl, it still references an internal
machine

how do i change this

http://192.159.100.81/MyWebService/Service1.asmx

to

http://mywebsite.com/MyWebService/Service1.asmx

in my visual studio project

thanks

If you set the "URL behavior" to Dynamic, then you will get a line in
the
web.config/app.config where you can define the URL.
Regardless of this, you can always set the URL from the code. See the
Url
property of the webservice class.

Hans Kesting




Jul 17 '06 #5

P: n/a
Yep. That's because your development machine has an internal Class C network
IP address, which is not a public internet address. If you want it to be
"mycompany.com" then it needs to be on a machine that faces the public
internet, or is in the DMZ zone or somehow has been mapped to a public IP
address. Your machine is just reporting what it is supposed to report - its
actual IP address on your internal network.

Peter

--
Co-founder, Eggheadcafe.com developer portal:
http://www.eggheadcafe.com
UnBlog:
http://petesbloggerama.blogspot.com


"hs" wrote:
Thanks for your input but i'm still lost.

My situation is as follows.
I have an asp.net webservice running on a development machine (created using
vs 2003).

the IT guys at my work place have exposed this development
machine/webservice to the web using microsoft ISA server 2004 (using a web
publishing rule).

however when i look at the wsdl for mywebservice, it still
refers to the local machine

<soap:address location=http://192.159.100.81/MyWebService/Service1.asmx />

all i'm trying to do is change this reference to

<soap:address
location=http://www.ourcompany.com/hsfolder/MyWebService/Service1.asmx />
Maybe my webservice needs to be in release mode or something. i'm a newbie
to all this thanks


"Peter Bromberg [C# MVP]" <pb*******@yahoo.nospammin.comwrote in message
news:1B**********************************@microsof t.com...
hs,
As was described, the Url property of your proxy class would override
this.
Just set the Url property before making any method calls.
Peter

--
Co-founder, Eggheadcafe.com developer portal:
http://www.eggheadcafe.com
UnBlog:
http://petesbloggerama.blogspot.com


"hs" wrote:
Hi Hans
thanks for your help. I tried what you have suggested but my wsdl still
has
this reference

<service name="Service1">
<port name="Service1Soap" binding="s0:Service1Soap">
<soap:address location=http://192.159.100.81/MyWebService/Service1.asmx
/>
</port>
</service>

'192.159.100.81' should be replaced with 'my.website.com' (for example).

any other ideas
thanks (much appreciated)
hs
"Hans Kesting" <ne***********@spamgourmet.comwrote in message
news:mn***********************@spamgourmet.com...
Hi
I have a webservice i created using visual studio 2003, and i want to
expose/deploy it to the internet.
my problem is when i open up the wsdl, it still references an internal
machine

how do i change this

http://192.159.100.81/MyWebService/Service1.asmx

to

http://mywebsite.com/MyWebService/Service1.asmx

in my visual studio project

thanks

If you set the "URL behavior" to Dynamic, then you will get a line in
the
web.config/app.config where you can define the URL.
Regardless of this, you can always set the URL from the code. See the
Url
property of the webservice class.

Hans Kesting




Jul 17 '06 #6

P: n/a
hs
Thanks for your input Peter

I've got further with this, the generated wsdl now shows 'mycomany.com'
instead of 'local machine' address.

after googling around, all i had to do was force ISA server to pass the
original header.

regards
hs

"Peter Bromberg [C# MVP]" <pb*******@yahoo.nospammin.comwrote in message
news:2B**********************************@microsof t.com...
Yep. That's because your development machine has an internal Class C
network
IP address, which is not a public internet address. If you want it to be
"mycompany.com" then it needs to be on a machine that faces the public
internet, or is in the DMZ zone or somehow has been mapped to a public IP
address. Your machine is just reporting what it is supposed to report -
its
actual IP address on your internal network.

Peter

--
Co-founder, Eggheadcafe.com developer portal:
http://www.eggheadcafe.com
UnBlog:
http://petesbloggerama.blogspot.com


"hs" wrote:
>Thanks for your input but i'm still lost.

My situation is as follows.
I have an asp.net webservice running on a development machine (created
using
vs 2003).

the IT guys at my work place have exposed this development
machine/webservice to the web using microsoft ISA server 2004 (using a
web
publishing rule).

however when i look at the wsdl for mywebservice, it still
refers to the local machine

<soap:address location=http://192.159.100.81/MyWebService/Service1.asmx
/>

all i'm trying to do is change this reference to

<soap:address
location=http://www.ourcompany.com/hsfolder/MyWebService/Service1.asmx />
Maybe my webservice needs to be in release mode or something. i'm a
newbie
to all this thanks


"Peter Bromberg [C# MVP]" <pb*******@yahoo.nospammin.comwrote in
message
news:1B**********************************@microso ft.com...
hs,
As was described, the Url property of your proxy class would override
this.
Just set the Url property before making any method calls.
Peter

--
Co-founder, Eggheadcafe.com developer portal:
http://www.eggheadcafe.com
UnBlog:
http://petesbloggerama.blogspot.com


"hs" wrote:

Hi Hans
thanks for your help. I tried what you have suggested but my wsdl
still
has
this reference

<service name="Service1">
<port name="Service1Soap" binding="s0:Service1Soap">
<soap:address
location=http://192.159.100.81/MyWebService/Service1.asmx
/>
</port>
</service>

'192.159.100.81' should be replaced with 'my.website.com' (for
example).

any other ideas
thanks (much appreciated)
hs
"Hans Kesting" <ne***********@spamgourmet.comwrote in message
news:mn***********************@spamgourmet.com. ..
Hi
I have a webservice i created using visual studio 2003, and i want
to
expose/deploy it to the internet.
my problem is when i open up the wsdl, it still references an
internal
machine

how do i change this

http://192.159.100.81/MyWebService/Service1.asmx

to

http://mywebsite.com/MyWebService/Service1.asmx

in my visual studio project

thanks

If you set the "URL behavior" to Dynamic, then you will get a line
in
the
web.config/app.config where you can define the URL.
Regardless of this, you can always set the URL from the code. See
the
Url
property of the webservice class.

Hans Kesting





Jul 20 '06 #7

This discussion thread is closed

Replies have been disabled for this discussion.