By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
455,170 Members | 1,360 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 455,170 IT Pros & Developers. It's quick & easy.

No Symbols loaded error - C#

P: n/a
JV
Hi All,

I am new to C# and I am having trouble compiling and running code. I
have the code written (it was just an example that I took) and I run
it, it gives me No Symbols loaded error as below.
Please let me know what is that I am doing wrong.
'DefaultDomain': Loaded
'c:\windows\microsoft.net\framework\v1.1.4322\msco rlib.dll', No symbols
loaded.
'TestSample': Loaded 'C:\Documents and Settings\mycomputername\My
Documents\Visual Studio
Projects\TestSample\TestSample\bin\Debug\TestSampl e.exe', Symbols
loaded.
The program '[3320] TestSample.exe' has exited with code 0 (0x0).

May 18 '06 #1
Share this Question
Share on Google+
3 Replies


P: n/a
"JV" <ss********@yahoo.com> wrote:
Hi All,

I am new to C# and I am having trouble compiling and running code. I
have the code written (it was just an example that I took) and I run
it, it gives me No Symbols loaded error as below.
Please let me know what is that I am doing wrong.

'DefaultDomain': Loaded
'c:\windows\microsoft.net\framework\v1.1.4322\msco rlib.dll', No symbols
loaded.
'TestSample': Loaded 'C:\Documents and Settings\mycomputername\My
Documents\Visual Studio
Projects\TestSample\TestSample\bin\Debug\TestSampl e.exe', Symbols
loaded.
The program '[3320] TestSample.exe' has exited with code 0 (0x0).


As far as I can see, this means your program ran and exited
*successfully* under the debugger.

If you debug your application using Mixed mode (i.e. project properties,
Debug tab, Enable unmanaged code debugging), it tries to load symbols
for each assembly or DLL as they are loaded. If you don't have the PDBs
for mscorlib.dll on your path, then obviously the symbols won't be
loaded.

-- Barry

--
http://barrkel.blogspot.com/
May 19 '06 #2

P: n/a
Barry Kelly <ba***********@gmail.com> wrote:
As far as I can see, this means your program ran and exited
*successfully* under the debugger.


I should point out that you don't need Unmanaged debugging or
mscorlib.dll symbols to debug any pure C# or managed code.

-- Barry

--
http://barrkel.blogspot.com/
May 19 '06 #3

P: n/a
I answered your first post of this exact same question. Tsk tsk.

--
HTH,

Kevin Spencer
Microsoft MVP
Professional Numbskull

The man who questions opinions is wise.
The man who quarrels with facts is a fool.

"JV" <ss********@yahoo.com> wrote in message
news:11*********************@u72g2000cwu.googlegro ups.com...
Hi All,

I am new to C# and I am having trouble compiling and running code. I
have the code written (it was just an example that I took) and I run
it, it gives me No Symbols loaded error as below.
Please let me know what is that I am doing wrong.
'DefaultDomain': Loaded
'c:\windows\microsoft.net\framework\v1.1.4322\msco rlib.dll', No symbols
loaded.
'TestSample': Loaded 'C:\Documents and Settings\mycomputername\My
Documents\Visual Studio
Projects\TestSample\TestSample\bin\Debug\TestSampl e.exe', Symbols
loaded.
The program '[3320] TestSample.exe' has exited with code 0 (0x0).

May 19 '06 #4

This discussion thread is closed

Replies have been disabled for this discussion.