By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
454,777 Members | 1,499 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 454,777 IT Pros & Developers. It's quick & easy.

Managed C++ Project not visible in C# Project -- Visual Studio 200

P: n/a
(If there is a better forum to post this in, please let me know...)

I am using Visual Studio 2005. I have a Solution consisting of three

* A main project "DiscoverNotes" written in C#
* A helper project, set as a /CLR DLL, in C++
* A test project in C#

Unfortunately, the using NotesApiAccessor line in the main project gives the

Error 1 The type or namespace name 'NotesApiAccessor' could not be
found (are you missing a using directive or an assembly reference?)
H:\DiscoverNotes\Controller.cs 8 7 DiscoverNotes

Everything compiles properly, including the C++ code, except for the above

The options for the C++ project command line are (in case I have selected an
incorrect option--this is my first foray into Managed C++):

/O2 /D "_WINDLL" /FD /MD /Fo"Debug\\" /Fd"Debug\vc80.pdb" /nologo /c /clr
/TP /errorReport:prompt

All three projects are in the same solution. I have created a reference for
the NotesApiAccessor project in the DiscoverNotes project, which my web
research tells me should be sufficient to make it work since all of the
projects are in the same solution.

The object browser correctly displays the objects in the NotesApiAccessor

I created a test project also in C# to see if I was accessing objects in
another project correctly, and using methods within that project from
DiscoverNotes works.

The NotesApiAccessor project is in C++ because it will be used to access an
API library which is provided only as a .LIB file and a set of C header
files--so I cannot simply use C#.

I would be very grateful for a pointer to some documentation I should read
or a hint on what I am doing wrong.

Apr 3 '06 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.