468,107 Members | 1,306 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 468,107 developers. It's quick & easy.

IDE keyboard goes whacky

Hi,

Sometimes when I am cutting and pasting it looks like the keyboard
layout changes; for instance ',' and 'w' are interchanged. Is there
a better way to fix this problem than exiting then restarting the IDE?

Thanks,
Mark
Feb 15 '06 #1
3 1745
nh******@newsgroup.nospam wrote:
Sometimes when I am cutting and pasting it looks like the keyboard
layout changes; for instance ',' and 'w' are interchanged. Is there
a better way to fix this problem than exiting then restarting the IDE?


This is a bit off topic, but you are inadvertently hitting a hotkey (by
default Left Alt + Shift) that changes the keyboard layout for the current
application between QWERTY and Dvorak. To turn this off:

1. Open the Control Panel->Regional and Language Options->Languages tab
2. Click Details. The Text Services and Input Languages dialog should
appear.
3. If no one who uses your machine uses the Dvorak layout, click Dvorak and
click Remove. If you do use it, click Key Settings and choose a key sequence
for "Switch between input languages" that you are not as likely to hit
accidentally.

I hope this helps.
--
Derrick Coetzee, MCAD, MSFT (Speech Server)
This posting is provided "AS IS" with no warranties, and confers no
rights.
Feb 16 '06 #2
The actual key sequence for switching keyboard layouts is Ctrl +
Shift; Left Alt + Shift switches input languages. On my notebook it
is way too easy to accidentely hit the Shift key while repeating Ctrl
+ c, Ctrl + v; when I removed Dvorak that is no problem.

Is there a list of Windows hotkeys active in the 20005 Pro IDE,
and/or a list of the IDE hotkeys?
Thanks,
Mark
On Thu, 16 Feb 2006 12:43:30 -0800, "Derrick Coetzee [MSFT]"
<dc******@online.microsoft.com> wrote:
nh******@newsgroup.nospam wrote:
Sometimes when I am cutting and pasting it looks like the keyboard
layout changes; for instance ',' and 'w' are interchanged. Is there
a better way to fix this problem than exiting then restarting the IDE?


This is a bit off topic, but you are inadvertently hitting a hotkey (by
default Left Alt + Shift) that changes the keyboard layout for the current
application between QWERTY and Dvorak. To turn this off:

1. Open the Control Panel->Regional and Language Options->Languages tab
2. Click Details. The Text Services and Input Languages dialog should
appear.
3. If no one who uses your machine uses the Dvorak layout, click Dvorak and
click Remove. If you do use it, click Key Settings and choose a key sequence
for "Switch between input languages" that you are not as likely to hit
accidentally.

I hope this helps.

Feb 19 '06 #3
nh******@newsgroup.nospam wrote:
Sometimes when I am cutting and pasting it looks like the keyboard
layout changes; for instance ',' and 'w' are interchanged. Is
there a better way to fix this problem than exiting then restarting
the IDE?


This is a bit off topic, but you are inadvertently hitting a hotkey
(by default Left Alt + Shift) that changes the keyboard layout for
the current application between QWERTY and Dvorak. To turn this off:


[...] On my notebook it is way too easy to accidentely hit the
Shift key while repeating Ctrl + c, Ctrl + v; when I removed
Dvorak that is no problem.

Is there a list of Windows hotkeys active in the 20005 Pro IDE,
and/or a list of the IDE hotkeys?


Most of them are listed here:

http://support.microsoft.com/default...b;en-us;301583

Besides the language hotkeys, a number of global hotkeys can be turned on
and off in the Accessibility Options. Just click every "Settings" button you
can find on every tab and uncheck "Use shortcut". You can also turn off
Windows+<letter> global hotkeys by using the NoWinKeys registry key,
described here:

http://technet2.microsoft.com/Window...e228a1033.mspx

There is a fairly comprehensive list of Visual Studio 2005 shortcut keys
here, but may be a bit out of date since it was made for Beta 2:

http://www.codinghorror.com/blog/fil...shortcuts.html

All Visual Studio shortcut keys are configurable, as described here:

http://msdn.microsoft.com/library/de...sDialogBox.asp

I hope this helps. In general, try to use the official term "shortcut keys"
when searching for information on this topic. Sorry for being horribly
off-topic. :-)
--
Derrick Coetzee, MCAD, MSFT (Speech Server)
This posting is provided "AS IS" with no warranties, and confers no
rights.
Feb 20 '06 #4

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

1 post views Thread by Keeper | last post: by
2 posts views Thread by Christoph BrŁser | last post: by
4 posts views Thread by teddysnips | last post: by
1 post views Thread by NvrBst | last post: by
2 posts views Thread by pelletier.thomas | last post: by
9 posts views Thread by Kbalz | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.