471,330 Members | 1,637 Online
Bytes | Software Development & Data Engineering Community
Post +

Home Posts Topics Members FAQ

Join Bytes to post your question to a community of 471,330 software developers and data experts.

Microsoft Unit testing

Hi all,

I converted our projects to .Net 2.0, and switched from using NUnit to
the MS UnitTesting framework.

Everything works fine, except in one assembly.

I have two test classes, each with a class setup and cleanup. For some
reason, Class A's setup fires, then Class B's setup, followed by Class
A's cleanup.

Because both classes end up using the same database table, class B's
tests always fail (because cleanup from A has not been completed).

I have noticed this anywhere else. Any ideas why the cleanup for A
isn't being called before moving onto B?

Thanks
Andy

Jan 23 '06 #1
0 817

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

4 posts views Thread by Hugh Cowan | last post: by
11 posts views Thread by rhat | last post: by
4 posts views Thread by Peter Rilling | last post: by
72 posts views Thread by Jacob | last post: by
4 posts views Thread by Dat AU DUONG | last post: by
5 posts views Thread by shuisheng | last post: by
176 posts views Thread by nw | last post: by
48 posts views Thread by Ark Khasin | last post: by
5 posts views Thread by Ben Finney | last post: by

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.