471,334 Members | 1,420 Online
Bytes | Software Development & Data Engineering Community
Post +

Home Posts Topics Members FAQ

Join Bytes to post your question to a community of 471,334 software developers and data experts.

Debugging a Snap in VS2003 with framwork 2.0 installed

I recently installed .Net Framework 2.0 on my computer. I have
developed a snap in c# using a library from sourceforge
(http://sourceforge.net/projects/mmclibrary/) on Visual Studio 2003
When I run my MMC project in debug mode from Visual Studio 2003 the mmc
starts up but crahes immediately. An hourglass appears and then the MMC
crashes. I have set up my project settings to start the program mmc.exe
with a command line argument of MySnapIn.msc I took out the command
line argument so that only the MMC will start. When I run the project
the MMC will start and I have to load the registered Snap In. When I do
an Add/Remove Snapin the list starts to populate but then the MMC
crashes. I do a load of the file MySnapIn.msc and the mms crashes.

When I run MMC.exe from Start>Run in windows and do a Add/Remove snap
in everything is OK. Also double clicking on MySnapIn.msc is fine. It
seems only when I run the MMC from Visual Studio 2003 this error
occurs. I uninstalled .Net Framework 2.0 and all my errors went away. I
do need .Net Framework 2.0 but it seems I cannot debug my Snap in any
more. Any help to solve this would be appreciated

Dec 21 '05 #1
1 1166
I believe you need to upgrade to VS2005 to work with 2.0 of the .NET Framework.
"Driez" wrote:
I recently installed .Net Framework 2.0 on my computer. I have
developed a snap in c# using a library from sourceforge
(http://sourceforge.net/projects/mmclibrary/) on Visual Studio 2003
When I run my MMC project in debug mode from Visual Studio 2003 the mmc
starts up but crahes immediately. An hourglass appears and then the MMC
crashes. I have set up my project settings to start the program mmc.exe
with a command line argument of MySnapIn.msc I took out the command
line argument so that only the MMC will start. When I run the project
the MMC will start and I have to load the registered Snap In. When I do
an Add/Remove Snapin the list starts to populate but then the MMC
crashes. I do a load of the file MySnapIn.msc and the mms crashes.

When I run MMC.exe from Start>Run in windows and do a Add/Remove snap
in everything is OK. Also double clicking on MySnapIn.msc is fine. It
seems only when I run the MMC from Visual Studio 2003 this error
occurs. I uninstalled .Net Framework 2.0 and all my errors went away. I
do need .Net Framework 2.0 but it seems I cannot debug my Snap in any
more. Any help to solve this would be appreciated

Dec 21 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

16 posts views Thread by Serdar Kalaycý | last post: by
5 posts views Thread by Velvet | last post: by
reply views Thread by Sericinus hunter | last post: by
3 posts views Thread by Herb | last post: by
1 post views Thread by moondaddy | last post: by
reply views Thread by rosydwin | last post: by

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.