By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
435,301 Members | 1,741 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 435,301 IT Pros & Developers. It's quick & easy.

<customErrors mode="Off"/> ERROR

P: n/a
I have a web application It works well in my local folder.. When i upload
it
to my web server i got

To enable the details of this specific error message to be viewable on
remote machines, please create a <customErrors> tag within a "web.config"
configuration file located in the root directory of the current web
application. This <customErrors> tag should then have its "mode" attribute
set to "Off".


Server Error in '/' Application.
--------------------------------------------------------------------------------

Runtime Error
Description: An application error occurred on the server. The current custom
error settings for this application prevent the details of the application
error from being viewed remotely (for security reasons). It could, however,
be viewed by browsers running on the local server machine.

Details: To enable the details of this specific error message to be viewable
on remote machines, please create a <customErrors> tag within a "web.config"
configuration file located in the root directory of the current web
application. This <customErrors> tag should then have its "mode" attribute
set to "Off".
Dec 19 '05 #1
Share this Question
Share on Google+
5 Replies


P: n/a
It means you application crashes on the server. Put the
customerrors-tag as listed in the web.config-file to see the
error-output.

Regards,
Sjur Rondestveit

Dec 19 '05 #2

P: n/a
Hi,

Usually when a web project works on a local machine but not on your
web host you are missing a dll referenced. I would check and make sure all
the dll files in your projects bin folder are on the bin folder on your web
host. Also adding that line to your web.config on your web host will give
you a lot more information about the error.

Ken
-------------
"Savas Ates" <sa***@indexinteractive.com> wrote in message
news:eZ**************@TK2MSFTNGP12.phx.gbl...
I have a web application It works well in my local folder.. When i upload
it
to my web server i got

To enable the details of this specific error message to be viewable on
remote machines, please create a <customErrors> tag within a "web.config"
configuration file located in the root directory of the current web
application. This <customErrors> tag should then have its "mode" attribute
set to "Off".


Server Error in '/' Application.
--------------------------------------------------------------------------------

Runtime Error
Description: An application error occurred on the server. The current
custom error settings for this application prevent the details of the
application error from being viewed remotely (for security reasons). It
could, however, be viewed by browsers running on the local server machine.

Details: To enable the details of this specific error message to be
viewable on remote machines, please create a <customErrors> tag within a
"web.config" configuration file located in the root directory of the
current web application. This <customErrors> tag should then have its
"mode" attribute set to "Off".

Dec 19 '05 #3

P: n/a
I copied all bin directory with dll's.. There is no problem about missing
files.. It is my web server. I have full access to change whatever i want ..
By the way what you mean

<< Put the
customerrors-tag as listed in the web.config-file to see the
error-output.

my web.config file
<customErrors mode="Off" />

any solution ?

"Savas Ates" <sa***@indexinteractive.com>, haber iletisinde şunları
yazdı:eZ**************@TK2MSFTNGP12.phx.gbl...
I have a web application It works well in my local folder.. When i upload
it
to my web server i got

To enable the details of this specific error message to be viewable on
remote machines, please create a <customErrors> tag within a "web.config"
configuration file located in the root directory of the current web
application. This <customErrors> tag should then have its "mode" attribute
set to "Off".


Server Error in '/' Application.
--------------------------------------------------------------------------------

Runtime Error
Description: An application error occurred on the server. The current
custom error settings for this application prevent the details of the
application error from being viewed remotely (for security reasons). It
could, however, be viewed by browsers running on the local server machine.

Details: To enable the details of this specific error message to be
viewable on remote machines, please create a <customErrors> tag within a
"web.config" configuration file located in the root directory of the
current web application. This <customErrors> tag should then have its
"mode" attribute set to "Off".

Dec 19 '05 #4

P: n/a
Isn't "Server Error in '/' Application" idicative of the virtual directory
not being marked as an application in IIS?

PS: I've also seen the <customErrors> message even when it is set to Off,
whenever there is a syntax error in the web.config.

Greg
"Savas Ates" <sa***@indexinteractive.com> wrote in message
news:eZ**************@TK2MSFTNGP12.phx.gbl...
I have a web application It works well in my local folder.. When i upload
it
to my web server i got

To enable the details of this specific error message to be viewable on
remote machines, please create a <customErrors> tag within a "web.config"
configuration file located in the root directory of the current web
application. This <customErrors> tag should then have its "mode" attribute
set to "Off".


Server Error in '/' Application.
--------------------------------------------------------------------------------

Runtime Error
Description: An application error occurred on the server. The current
custom error settings for this application prevent the details of the
application error from being viewed remotely (for security reasons). It
could, however, be viewed by browsers running on the local server machine.

Details: To enable the details of this specific error message to be
viewable on remote machines, please create a <customErrors> tag within a
"web.config" configuration file located in the root directory of the
current web application. This <customErrors> tag should then have its
"mode" attribute set to "Off".

Dec 19 '05 #5

P: n/a
do exactly what the error tells you. open the web.config
and change
<customErrors
mode="RemoteOnly"
/>

to <customErrors
mode="Off"
/>
thou shalt google before asking...

Savas Ates wrote:
I copied all bin directory with dll's.. There is no problem about missing
files.. It is my web server. I have full access to change whatever i want..
By the way what you mean

<< Put the
customerrors-tag as listed in the web.config-file to see the
error-output.

my web.config file
<customErrors mode="Off" />

any solution ?

"Savas Ates" <sa***@indexinteractive.com>, haber iletisinde şunları
yazdı:eZ**************@TK2MSFTNGP12.phx.gbl...
I have a web application It works well in my local folder.. When i upload
it
to my web server i got

To enable the details of this specific error message to be viewable on
remote machines, please create a <customErrors> tag within a "web.config"
configuration file located in the root directory of the current web
application. This <customErrors> tag should then have its "mode" attribute
set to "Off".


Server Error in '/' Application.
--------------------------------------------------------------------------------

Runtime Error
Description: An application error occurred on the server. The current
custom error settings for this application prevent the details of the
application error from being viewed remotely (for security reasons). It
could, however, be viewed by browsers running on the local server machine.

Details: To enable the details of this specific error message to be
viewable on remote machines, please create a <customErrors> tag within a
"web.config" configuration file located in the root directory of the
current web application. This <customErrors> tag should then have its
"mode" attribute set to "Off".


Dec 19 '05 #6

This discussion thread is closed

Replies have been disabled for this discussion.