471,570 Members | 1,102 Online
Bytes | Software Development & Data Engineering Community
Post +

Home Posts Topics Members FAQ

Join Bytes to post your question to a community of 471,570 software developers and data experts.

Failed to access IIS metabase

I'm creating a web app using VS 2005. When I run the app I receive the error,

"Failed to access IIS metabase"

How do I correct this problem?

Thanks for you help.
Dec 12 '05 #1
4 2954
Dave,

Did you change the credentials to allow you to access the IIS metabase?
By default, ASP applications run under the ASPNET user, which is a local
user account, and does not have access to the IIS metabase.

Hope this helps.
--
- Nicholas Paldino [.NET/C# MVP]
- mv*@spam.guard.caspershouse.com

"Dave" <Da**@discussions.microsoft.com> wrote in message
news:96**********************************@microsof t.com...
I'm creating a web app using VS 2005. When I run the app I receive the
error,

"Failed to access IIS metabase"

How do I correct this problem?

Thanks for you help.

Dec 13 '05 #2
I ran

aspnet_regiis –ga aspnet

I said it change the metabase, however I still have the same problem. How do
I fix it?

"Nicholas Paldino [.NET/C# MVP]" wrote:
Dave,

Did you change the credentials to allow you to access the IIS metabase?
By default, ASP applications run under the ASPNET user, which is a local
user account, and does not have access to the IIS metabase.

Hope this helps.
--
- Nicholas Paldino [.NET/C# MVP]
- mv*@spam.guard.caspershouse.com

"Dave" <Da**@discussions.microsoft.com> wrote in message
news:96**********************************@microsof t.com...
I'm creating a web app using VS 2005. When I run the app I receive the
error,

"Failed to access IIS metabase"

How do I correct this problem?

Thanks for you help.


Dec 15 '05 #3
After doing that you need to open up iss go to the web site in question,
select properties, then the "Operators" tab. Then add the aspnet user. That
fixed my problem.

"Dave" wrote:
I ran

aspnet_regiis –ga aspnet

I said it change the metabase, however I still have the same problem. How do
I fix it?

"Nicholas Paldino [.NET/C# MVP]" wrote:
Dave,

Did you change the credentials to allow you to access the IIS metabase?
By default, ASP applications run under the ASPNET user, which is a local
user account, and does not have access to the IIS metabase.

Hope this helps.
--
- Nicholas Paldino [.NET/C# MVP]
- mv*@spam.guard.caspershouse.com

"Dave" <Da**@discussions.microsoft.com> wrote in message
news:96**********************************@microsof t.com...
I'm creating a web app using VS 2005. When I run the app I receive the
error,

"Failed to access IIS metabase"

How do I correct this problem?

Thanks for you help.


Dec 15 '05 #4
Hi,

I am also facing same problem

Have you got any solution for that ?

With Best Regards,

Naimish
Jan 20 '06 #5

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

1 post views Thread by David | last post: by
3 posts views Thread by Microsoft | last post: by
5 posts views Thread by David Veeneman | last post: by
reply views Thread by Will Holley | last post: by
2 posts views Thread by Kivak Wolf | last post: by
2 posts views Thread by John | last post: by
reply views Thread by XIAOLAOHU | last post: by
reply views Thread by leo001 | last post: by
reply views Thread by Vinnie | last post: by
reply views Thread by lumer26 | last post: by

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.