471,605 Members | 1,596 Online
Bytes | Software Development & Data Engineering Community
Post +

Home Posts Topics Members FAQ

Join Bytes to post your question to a community of 471,605 software developers and data experts.

axWebBrowser control

Hi,

My question is very simple I am sure but I cant seem to find a solution
anywhere....

I have a windows form in C# and I have added an axWebBrowser control. When
the form loads I am trying to display a web page in the control.... but I
have tried Navigate and Navigate2 methods and whatever I try nothing is
displayed... The code that I am using in the forms load event is

object oURL = "http://www.microsoft.com";
object oEmpty = "";
axWebBrowser1.Navigate2(ref oURL, ref oEmpty, ref oEmpty, ref oEmpty, ref
oEmpty);

which I got from Microsoft web site

Can anyone explain what I need to do to have the web page display?
Dec 6 '05 #1
2 1471
Additional Info:

The form I am using is an MdiChild form.... when I run the code on a
standard form it displays the web page correctly.... how do I get the
axWebBrowser control to work on an MDIchild form?

Many thanks in advance

"hplloyd" wrote:
Hi,

My question is very simple I am sure but I cant seem to find a solution
anywhere....

I have a windows form in C# and I have added an axWebBrowser control. When
the form loads I am trying to display a web page in the control.... but I
have tried Navigate and Navigate2 methods and whatever I try nothing is
displayed... The code that I am using in the forms load event is

object oURL = "http://www.microsoft.com";
object oEmpty = "";
axWebBrowser1.Navigate2(ref oURL, ref oEmpty, ref oEmpty, ref oEmpty, ref
oEmpty);

which I got from Microsoft web site

Can anyone explain what I need to do to have the web page display?

Dec 6 '05 #2
Hi,
You are using the activex control.
You should use System.Windows.Forms.WebBroser,
which is probably a wrapper to the com obj.
Anyway, as far as i remember, you only have to set the url
property on WebBrowser and the web page loads automatically.
Hope this helps.
Sharon.

"hplloyd" <hp*****@discussions.microsoft.com> wrote in message
news:8D**********************************@microsof t.com...
Hi,

My question is very simple I am sure but I cant seem to find a solution
anywhere....

I have a windows form in C# and I have added an axWebBrowser control. When
the form loads I am trying to display a web page in the control.... but I
have tried Navigate and Navigate2 methods and whatever I try nothing is
displayed... The code that I am using in the forms load event is

object oURL = "http://www.microsoft.com";
object oEmpty = "";
axWebBrowser1.Navigate2(ref oURL, ref oEmpty, ref oEmpty, ref oEmpty, ref
oEmpty);

which I got from Microsoft web site

Can anyone explain what I need to do to have the web page display?

Dec 11 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

reply views Thread by Lecture Snoddddgrass | last post: by
reply views Thread by Matthias Kwiedor | last post: by
1 post views Thread by Mantorok | last post: by
reply views Thread by beau | last post: by
3 posts views Thread by Clint MacDonald | last post: by
6 posts views Thread by Dave Booker | last post: by
reply views Thread by tamarindm | last post: by
1 post views Thread by XIAOLAOHU | last post: by
reply views Thread by leo001 | last post: by
reply views Thread by MichaelMortimer | last post: by

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.