471,348 Members | 1,324 Online
Bytes | Software Development & Data Engineering Community
Post +

Home Posts Topics Members FAQ

Join Bytes to post your question to a community of 471,348 software developers and data experts.

Control Event not firing

Hi,

I've created a webControl with a list of buttons. Each of the buttons has a
CommandEventHandler attached but when they are clicked the corresponding
postback does not enter the associated event mehod, Can anyone help please.

Jim
Dec 2 '05 #1
4 1503
Jim,

You have to post an example, as your scenario (while vague) doesn't
indicate that you are doing anything wrong.
--
- Nicholas Paldino [.NET/C# MVP]
- mv*@spam.guard.caspershouse.com

"Jimmy Jazz" <Ji*******@discussions.microsoft.com> wrote in message
news:A4**********************************@microsof t.com...
Hi,

I've created a webControl with a list of buttons. Each of the buttons has
a
CommandEventHandler attached but when they are clicked the corresponding
postback does not enter the associated event mehod, Can anyone help
please.

Jim

Dec 2 '05 #2
Hi,

Unless he is creating the control dynamically, if so the controls have to be
recreated in the postback
cheers,

--
Ignacio Machin,
ignacio.machin AT dot.state.fl.us
Florida Department Of Transportation


"Nicholas Paldino [.NET/C# MVP]" <mv*@spam.guard.caspershouse.com> wrote in
message news:uB**************@TK2MSFTNGP14.phx.gbl...
Jim,

You have to post an example, as your scenario (while vague) doesn't
indicate that you are doing anything wrong.
--
- Nicholas Paldino [.NET/C# MVP]
- mv*@spam.guard.caspershouse.com

"Jimmy Jazz" <Ji*******@discussions.microsoft.com> wrote in message
news:A4**********************************@microsof t.com...
Hi,

I've created a webControl with a list of buttons. Each of the buttons has
a
CommandEventHandler attached but when they are clicked the corresponding
postback does not enter the associated event mehod, Can anyone help
please.

Jim


Dec 2 '05 #3
Hi,

Yes I am creating them dynamically. How do you mean create them in the
postback do you have an example?

"Ignacio Machin ( .NET/ C# MVP )" wrote:
Hi,

Unless he is creating the control dynamically, if so the controls have to be
recreated in the postback
cheers,

--
Ignacio Machin,
ignacio.machin AT dot.state.fl.us
Florida Department Of Transportation


"Nicholas Paldino [.NET/C# MVP]" <mv*@spam.guard.caspershouse.com> wrote in
message news:uB**************@TK2MSFTNGP14.phx.gbl...
Jim,

You have to post an example, as your scenario (while vague) doesn't
indicate that you are doing anything wrong.
--
- Nicholas Paldino [.NET/C# MVP]
- mv*@spam.guard.caspershouse.com

"Jimmy Jazz" <Ji*******@discussions.microsoft.com> wrote in message
news:A4**********************************@microsof t.com...
Hi,

I've created a webControl with a list of buttons. Each of the buttons has
a
CommandEventHandler attached but when they are clicked the corresponding
postback does not enter the associated event mehod, Can anyone help
please.

Jim



Dec 2 '05 #4
Heres a couple of links you should look at.
http://msdn.microsoft.com/library/de...nlifecycle.asp
and http://weblogs.asp.net/vga/archive/2.../11/23498.aspx .

My guess is that you should focus on page load() I think that is what you
are missing.

Hth

Denis

"Jimmy Jazz" <Ji*******@discussions.microsoft.com> wrote in message
news:A0**********************************@microsof t.com...
Hi,

Yes I am creating them dynamically. How do you mean create them in the
postback do you have an example?

"Ignacio Machin ( .NET/ C# MVP )" wrote:
Hi,

Unless he is creating the control dynamically, if so the controls have to be recreated in the postback
cheers,

--
Ignacio Machin,
ignacio.machin AT dot.state.fl.us
Florida Department Of Transportation


"Nicholas Paldino [.NET/C# MVP]" <mv*@spam.guard.caspershouse.com> wrote in message news:uB**************@TK2MSFTNGP14.phx.gbl...
Jim,

You have to post an example, as your scenario (while vague) doesn't
indicate that you are doing anything wrong.
--
- Nicholas Paldino [.NET/C# MVP]
- mv*@spam.guard.caspershouse.com

"Jimmy Jazz" <Ji*******@discussions.microsoft.com> wrote in message
news:A4**********************************@microsof t.com...
> Hi,
>
> I've created a webControl with a list of buttons. Each of the buttons has> a
> CommandEventHandler attached but when they are clicked the corresponding> postback does not enter the associated event mehod, Can anyone help
> please.
>
> Jim


Dec 2 '05 #5

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

reply views Thread by Mike | last post: by
4 posts views Thread by Dan Soendergaard | last post: by
2 posts views Thread by tshad | last post: by

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.