469,602 Members | 2,143 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,602 developers. It's quick & easy.

Workaround: Slow steping in debugging in VB2005

I know some of you have seen this problem. Stepping through code in the
debugger is slow as heck in Visual Studio 2005. Well here is the problem,
Edit and continue. Because edit and continue does run time compileing of
code as it executes, it causes a big slow down in execution time. To disable
this and return the debugger to the normal speed as it was in VS.NET 2003,
do the following.

Go to tools menu > options

Select debugging form the left tree expand it
click on Edit and Continue in the list.

Uncheck "Enable edit and continue"

rebuild your project and step through code, it should be fast as VS.NET 2003
was now.
Nov 17 '05 #1
1 1358
Brian,

I'd like to get some information this issue.

1) How many projects do you have in your solution?

2) What are the specs on your machine: memory, CPU, disk size

3) Does this happen all the time or only in certain cases?

Habib Heydarian (ha****@microsoft.com)
Program Manager
Visual Studio Debugger

--------------------
From: "Brian Henry" <no****@nospam.com>
Subject: Workaround: Slow steping in debugging in VB2005
Date: Wed, 9 Nov 2005 15:11:07 -0500
Lines: 18
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.3790.1830
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.1830
X-RFC2646: Format=Flowed; Original
Message-ID: <ub**************@tk2msftngp13.phx.gbl>
Newsgroups: microsoft.public.dotnet.languages.csharp,microsoft .public.dotnet.languages.v
b,microsoft.public.vsnet.ideNNTP-Posting-Host: reschini.010.stargate.net 209.114.179.10
Path: TK2MSFTNGXA02.phx.gbl!TK2MSFTNGP08.phx.gbl!tk2msft ngp13.phx.gbl
Xref: TK2MSFTNGXA02.phx.gbl microsoft.public.dotnet.languages.vb:303371 microsoft.public.vsnet.ide:17227
microsoft.public.dotnet.languages.csharp:363945X-Tomcat-NG: microsoft.public.dotnet.languages.csharp

I know some of you have seen this problem. Stepping through code in the
debugger is slow as heck in Visual Studio 2005. Well here is the problem,
Edit and continue. Because edit and continue does run time compileing of
code as it executes, it causes a big slow down in execution time. To disablethis and return the debugger to the normal speed as it was in VS.NET 2003,
do the following.

Go to tools menu > options

Select debugging form the left tree expand it
click on Edit and Continue in the list.

Uncheck "Enable edit and continue"

rebuild your project and step through code, it should be fast as VS.NET 2003was now.


Nov 17 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

5 posts views Thread by Will McGugan | last post: by
1 post views Thread by Jeffrey Roughgarden | last post: by
7 posts views Thread by Fredrik Melin | last post: by
3 posts views Thread by michael | last post: by
10 posts views Thread by Doug Robertson | last post: by
7 posts views Thread by Galen Somerville | last post: by
reply views Thread by guiromero | last post: by
reply views Thread by devrayhaan | last post: by
reply views Thread by gheharukoh7 | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.